
Reference Manual

Flexview
Multibeam Sonar





922-20207001/1.3
December 2022 © Kongsberg Maritime

Canada Limited

Flexview
Multibeam sonar
Reference Manual

Release 1.3

This manual provides you with reference information required to
operate and fully understand the commands, menus, modes and options
provided by the Kongsberg Flexview Multibeam sonar.



Kongsberg Maritime Canada Limited
www.kongsberg.com

Document information
• Product: Kongsberg Flexview
• Document: Reference Manual
• Document number: 922-20207001
• Revision: 1.3
• Date of issue: 14 December 2022

Copyright
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Limited. No part of this document may be copied or reproduced in any form or by any means, and the
information contained within it is not to be communicated to a third party, without the prior written
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Warning
The equipment to which this manual applies must only be used for the purpose for which it was
designed. Improper use or maintenance may cause damage to the equipment and/or injury to personnel.
You must be familiar with the contents of the appropriate manuals before attempting to operate
or work on the equipment.

Kongsberg Mesotech disclaims any responsibility for damage or injury caused by improper installation,
use or maintenance of the equipment.

Disclaimer
Kongsberg Maritime Canada Limited endeavours to ensure that all information in this document is correct
and fairly stated, but does not accept liability for any errors or omissions.

Support information
If you require maintenance or repair, contact your local dealer. You can contact us by phone at
+1 604 464 8144, or by email at: km.support.vancouver@km.kongsberg.com. If you need information
about our other products, visit http://www.km.kongsberg.com/mesotech. On our website you will also find
a list of our dealers and distributors.
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About this manual

The purpose of this publication is to provide the descriptions, procedures and detailed
parameter explanations required to allow for safe and efficient use of the Flexview
system. The publication also provides you with a thorough understanding of the
parameters and adjustments provided by the Flexview system.

Target audience

This publication is intended for all users of the Flexview system. Due to the nature of
the descriptions and the level of detail provided by this publication, it is well suited for
those who are - or wish to be - expert users.

A good understanding of system functions and controls is essential to fully take
advantage of the functionality provided. A careful study of the information in this
manual is highly recommended, preferably while exploring the functionality offered
by the Flexview system.

We assume that you are familiar with the basic acoustic principles of sound in water. We
also expect that you have some experience with sonar operation.

License information

The Flexview Software is included with the Flexview system and
updates are available free of charge and can be downloaded from:
http://www.kongsberg.com/mesotechsoftware.

Software version

This Flexview Reference Manual complies with Flexview software version 1.3.1.

Registered trademarks

Observe the registered trademarks that apply.

Windows® is a registered trademark of Microsoft Corporation in the United States and
other countries.

About this manual

http://www.kongsberg.com/mesotechsoftware
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We want your feedback

We always want to improve our products. We also want our end-user documentation to
be comprehensive and relevant. You can help. Please provide comments, suggestions
or constructive criticism to our support office. You can contact us by phone at
+1 604 464 8144, or by email at: km.support.vancouver@km.kongsberg.com.

Flexview Reference Manual
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System description
The Kongsberg Mesotech Flexview is a compact, versatile multibeam sonar.

The Flexview is designed for small observation-class
ROVs where compact size and light weight are key
selection criteria. Flexible and efficient, it is suitable
for applications such as site inspection, clearance,
marine engineering, underwater science, environmental
monitoring, or search-and-rescue assignments.

The removable transducer on the Flexview is the first
of its kind, offering field replacement of a damaged
transducer in the unlikely event of a catastrophic
impact. This innovative design also allows for
transducer configurations to be exchanged, depending
on the job being performed. For example, a low-frequency transducer can detect objects
at a long range, whereas a high-frequency transducer provides high-resolution images
at short range.

Multibeam sonars have an array of transducers that simultaneously transmits pings
(sound pulses) at a specified frequency to cover a large area in less time than a
single-beam transducer. To generate data, computer software assigns a colour range
corresponding to the amount of sound reflected off a target. The distance to the target is
determined by the length of time it took to receive the transmitted acoustic pulse.

The Flexview provides wide-angle full-range
situational awareness and concurrent ultra-short range
imaging with dynamic focusing.

By combining the high refresh rate of a conventional
multibeam sonar with an image quality comparable
to a single-beam sonar, the Flexview provides
high-resolution images that are easy to interpret. The
Flexview has a 140° field of view, allowing you to see
the full underwater picture in real-time.

Flexview Reference Manual
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System diagram
The system diagram identifies the main components of a basic Flexview system. Only
the main connections between the units are shown. Detailed interface capabilities and
power cables are not shown.

A ROV Topside Unit
B Sonar Processor
C ROV Junction Box / MUX
D Flexview Sonar Head

Flexview
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System units

Topics
Sonar Processor, page 13

Power supply, page 13

Sonar Head, page 14

Flexview Reference Manual
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Sonar Processor
In this publication, the computer can also be referred to as the Processor Unit, and
vice versa. The Sonar Processor contains the operational software, and offers the user
interface that allows you to control the Flexview. It is a vital part of the Flexview system.

The Sonar Processor runs the Flexview software
that manages communication with the Sonar Head,
performs all beamforming and image processing and
presents the sonar imagery. The Sonar Processor
communicates with the sonar through a standard
Ethernet cable.

If you purchase a computer locally, make sure that
the chosen model meets the functional and technical
requirements. The computer must be designed for
rugged use. The construction must be able to withstand the vibrations and movements of
a vessel.

Related topics
Minimum computer requirements, page 168

Power supply
The Sonar Head requires a DC power supply to run.

Normally, the DC voltage is supplied in the location where the Sonar Head is mounted,
such as on a remotely operated vehicle (ROV). A test cable and power supply is available
for order as an accessory. The test power supply uses a 24 VDC switching power supply.

Related topics
Power requirements, page 167

Flexview
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Sonar Head
The Sonar Head transmits and receives an acoustic pulse when deployed underwater.

The removable transducer on the Flexview is the first of its kind, offering field
replacement of a damaged transducer in the unlikely event of a catastrophic impact. This
innovative design also allows for transducer configurations to be exchanged, depending
on the job being performed. There are transducers with varying frequencies available for
the Flexview. The 500 kHz and 700-1400 kHz transducers are shown here.

The Sonar Head includes transmit and receive transducers and the electronics to generate
the transmit pulse and digitize the received signal. The sonar data is sent to the Sonar
Processor using a standard Ethernet link.

Caution

The Sonar Head’s black polyurethane transducer is delicate. Avoid impacts to the
transducer when installing or handling the Flexview.

Prolonged exposure to ultra-violet rays and excessive heat may damage the surface of
the polyurethane transducer face. Always store the Flexview in the provided equipment
case when not in use. If the Flexview is mounted on an ROV, cover the transducer
when not in use.

Related topics
Performance specifications, page 164
Mechanical specifications, page 166

Support information
If you need technical support for your Flexview you must contact your local dealer, or
our support department.

If you require maintenance or repair, contact your local dealer. You can contact us by
phone at +1 604 464 8144, or by email at: km.support.vancouver@km.kongsberg.com.
If you need information about our other products, visit http://www.km.kongs-
berg.com/mesotech. On our website you will also find a list of our dealers and
distributors.

Flexview Reference Manual
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Getting started

Topics
Turning the Flexview system on and off, page 16

Starting normal operation, page 18

Getting started
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Turning the Flexview system on and off

Topics
Turning on the Flexview system, page 16

Turning off the Flexview system, page 17

Turning on the Flexview system
To use the Flexview system, you must turn it on. You must first turn on the display and
the computer. After this you can start the Flexview software.

Prerequisites
• The system units have all been installed according to the instructions provided.
• All cable connections have been made and checked.
• All system units have been inspected.

Context

The program is not automatically started when the computer is turned on. On the Sonar
Processor desktop, double-click the Flexview icon to start the software.

Note

The Flexview is not provided with an on/off switch.

Procedure
1 Power up the Sonar Head using the power supply.

Note

It may take up to 60 seconds for the Flexview software to connect to the Sonar
Head once the power is applied.

2 Turn on the computer.

Wait while the operating system loads.
3 Log in to Windows.
4 On the Sonar Processor desktop, double-click the Flexview icon to start the

software.

Flexview Reference Manual
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5 Once the program has started, observe that the display presentation fills the entire
screen.

The software starts up using many of the same settings as the last time you used it.
If these settings are acceptable, continue operation. If you wish to alter any of the
settings, see the relevant procedures.

6 Click Setup→Connect to start the Sonar Head.

The sonar will start pinging automatically once the connection is complete. Observe
that the text “Active” appears in the lower-right corner of the status bar.

Turning off the Flexview system
The Flexview is not provided with an on/off switch.

Context
When you do not use the Flexview system, turn it off.

Procedure
1 If you are running the sonar, click Setup→Disconnect in the Flexview software.
2 Switch off the Sonar Processor.

a Close the Flexview software and any third-party software.
b Shut down Windows.

3 Disconnect the power cord leading to the power supply.

Alternatively, switch off the breaker supplying power to the Flexview.
4 Switch off any additional items, such as a sound velocity profiler or display.

If required, refer to the instructions provided by the product’s manufacturer.

Getting started
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Starting normal operation

Topics
Introduction to the basic procedures, page 18

Setting the Sonar Processor to High Performance, page 19

Installing the Flexview software, page 20

Defining the IP address on the computer's network adapter, page 21

Changing the frequency, page 21

Testing operation of the Sonar Head, page 22

Testing the Sonar Head telemetry, page 24

Introduction to the basic procedures
Once you have powered up the complete Flexview system, and started the Flexview
program, you are ready to start the actual operation.

Observe these brief procedures to familiarize yourself with the basic operation.

When starting up, the Flexview will automatically apply its previous settings. The
procedures are partly provided to get you acquainted with the basic functionality offered
by the Flexview, and partly to set up the Flexview for normal use. If you already know
the current operational settings are acceptable, you may not need to do any of these
procedures.

Flexview Reference Manual
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Setting the Sonar Processor to High Performance
To avoid slowdowns or disruptions while running the sonar, ensure your Sonar Processor
is using all of its processing power and does not go to sleep.

Prerequisites

This procedure is made for the Microsoft® 64-bit Windows 10 operating system.

Procedure
1 In the bottom-left corner of your desktop, select the Windows® Start button.
2 On the menu, select Settings.

Observe that the Settings window opens.
3 Select System.
4 In the menu on the left, select Power & sleep.
5 Make sure that the Sonar Processor will never go to sleep when plugged in.

a Click the Additional power settings link on the right side of the window.
Observe that the Power Options dialog box opens.

b In the menu on the left, select Create a power plan.
c Select the High performance radio button.
d Give your new custom plan a name, then click Next.
e Select Never for both Turn off the display and Put the computer to sleep when

plugged in.
f Click Create.

Tip

Once you have created a custom plan, you can adjust some more advanced settings.
You may, for example, wish to keep any secondary displays on when the laptop lid
is closed. Click Change plan settings next to your custom plan. Click the Change
advanced power settings link. Observe that the Power Options dialog box opens.
Click the “+” to expand the submenus, then select the desired options from the
drop-down lists. At the bottom of the dialog box, select Apply to save your settings.

Getting started
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Installing the Flexview software
If your system is provided with a Sonar Processor, the Flexview software has already
been installed. If you intend to use your own computer, you must install the software
yourself. We recommended installing the latest Flexview software on your Sonar
Processor.

Prerequisites
• You will need the Kongsberg USB drive included with the system or download the

latest Flexview software release from: http://www.kongsberg.com/mesotechsoftware.
• If you are installing a new software version, uninstall the previous version of the

Flexview software before proceeding.

Note

When running the Flexview software for the first time, a Windows Firewall dialog box
may appear. Allow access for all networks.

Procedure
1 Launch the installer Flexview_V0131 Setup.exe.
2 Follow the installation wizard’s instructions.

a When prompted, use the default folder location.
b When prompted, check the Create a desktop shortcut box.
c Click Yes to install the KML USB Converter when prompted and follow the

instructions to finish the installation process.
3 Pin the Flexview software icon to the Windows Taskbar.

a Right click on the Flexview software icon.
b Click Pin to taskbar.

4 Test the Flexview software startup.
a Double click the Flexview icon on the desktop to run the Flexview software.
b Confirm the software finishes launching without any error windows appearing.

Flexview Reference Manual
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Defining the IP address on the computer's network adapter
The communication between the Sonar Processor and the Sonar Head is made using a
high-speed Ethernet cable. If a Sonar Processor is not configured to connect to the sonar,
you must define which IP Address and Subnet mask the Ethernet adapter in the Sonar
Processor shall use for this communication.

Prerequisites

This procedure is made for the Microsoft® 64-bit Windows 10 operating system. It
is assumed that you are familiar with the Windows® operating systems, computer
technology, and interface principles.

Context

As long as you do not change the Sonar Processor to another computer, or replace the
serial adapter in your Sonar Processor, you will only need to do this once.

Procedure
1 On the computer, close the Flexview software.
2 Open the Network Connections dialog box.

a In the bottom-left corner of your desktop, select the Windows® search function.
b In the search box, type "Network Connections", and open the Network

Connections dialog box.
c Right-click the network adapter you are going to use and select Properties

on the shortcut menu.
d On the list of connections, select Internet Protocol 4 (TCP/IPv4), and then

Properties.
3 Select Use the following IP address, and type the IP address and network mask.

IP Address: 192.168.001.N ("N" can be any number from 1 to 254, except 234,
which is the Sonar Head default.)

Subnet mask: 255.255.255.0

You can leave Default Gateway blank.
4 Select OK to save the settings, then close all the dialog boxes.

Changing the frequency
If you have a high-frequency Flexview transducer, you can change the frequency using
the Display Widget.

Context

There are transducers with varying frequencies available for the Flexview.

Getting started
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Note

The frequency buttons will not appear if you are using a 500 kHz transducer. In addition,
these buttons will not appear in playback mode.

Procedure
1 Click the Display Widget icon.

This icon is located in the lower-right
corner of the sonar view.

2 Click one of the buttons to select a
frequency (in kHz).

3 Click the Display Widget icon to hide
the widget.

Note

You cannot select a sonar application
or change the range until you
connect to a Sonar Head (Click
Setup→Connect).

Testing operation of the Sonar Head
You can test the operation of the Sonar Head by confirming that sonar data is being
correctly displayed in the Information Widget and sonar view. In addition, any errors will
be displayed in the Output Messages or Head Status windows.

Prerequisites

The Flexview software must be running.

Tip

Make sure there is sufficient disk space available to complete the survey.

Flexview Reference Manual
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Procedure
1 Click Setup→Connect to start the Sonar Head.

Make sure that a sonar image appears in the sonar view window.

2 Click the “i” icon in the top-left corner of the sonar view to open the Information
Widget.

Make sure that the sensor data is updating in the
Information Widget.

3 Make sure that no errors are displayed in the Output
Messages window.
a Click Display→Output Messages Window.
b Make sure there are no errors shown in the

Output Messages window under the Host
Messages or Head Messages tab.

4 Make sure there are no errors in the Connection
Status and Head Status windows.
a Click on the text “Active” located in the

lower-right corner of the status bar.

Observe that the Connection Status window
opens.

b Make sure that all items listed under the FlexviewSonar show check marks.

If any items are shown with an “X” in a red circle, it usually means the device
has failed to connect. Disconnect and make sure that no sensors have failed.

c Click on the top line in the Connection Status window.

Observe that the Head Status window opens.

Getting started
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d Make sure that all parameters in the list are shown with a check mark inside a
green circle.

5 Make sure there is no acoustic or electrical interference in the sonar view.

A Make sure that no concentric rings appear. These rings could be caused by
other acoustic devices or power-line noise. Rings with black gaps between
them could also be due to excess Ethernet traffic when using a shared network.

B Make sure that there isn’t a bright radial line originating from the Sonar Head.
This line could be caused by thruster noise. If the radial line appears with the
Sonar Head out of water, it could indicate noise in the power line or a fault in
the Sonar Head.

C Make sure that the bottom appears across the entire width of the sonar view.
If the edges appear weak, and profile points are not detected at the edges,
make sure there are no obstructions preventing the Sonar Head’s receive. (for
example, proximity to the vessel hull/keel).

Related topics
System Configuration dialog box - Sonar Setup page, page 113

Testing the Sonar Head telemetry
You can run a telemetry test to make sure the link between the Sonar Head and the
Flexview software is working correctly.

Prerequisites
• For this test you will need the Sonar Head connected to the Sonar Processor and

powered on.
• The Flexview software must be running.
• This procedure is made for the Microsoft® 64-bit Windows 10 operating system. It

is assumed that you are familiar with the Windows® operating systems, computer
technology, and interface principles.

Context

This procedure explains how to measure the available bandwidth on a 100Base-TX
(100 Mbps) Ethernet link. The same procedure can be used for a 10BaseT link by
selecting the appropriate sonar application and adjusting the Ethernet adapter settings
to the corresponding link speed.

Flexview Reference Manual
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Note

There are no standard sonar applications with a telemetry-link speed requirement
higher than 100 Mbps.

The ping rate is normally taken from the sonar application or range setting. If the
estimated available bandwidth is less than the bandwidth required by the sonar
application/range, the Flexview software reduces the ping rate to compensate.

Note

The update rate is the number of times the sonar view is updated per second. The
displayed ping rate may be different from the update rate because the system might
be impacted by other processes.

The Override Network Link Speed function allows you to use the telemetry bandwidth
value (in Mbps) entered into the box instead of the default speed. If the applied
override telemetry bandwidth is less than the telemetry bandwidth required by the sonar
application/range, the ping rate is reduced.

Procedure
1 Click Setup→Connect to start the Sonar Head.
2 Add the Ethernet Test application to your list of favourite applications.

a Open the Sonar Apps menu on the top bar, then select Customize Apps.
b Double click on Ethernet Test - 100Mbps shown under Other Apps.
c Click OK.

3 Open the Sonar Apps menu on the top bar, then select Ethernet Test - 100Mbps.
4 Open the Task Manager and find your Local Area Connection.

a Press the <CTRL> + <ALT> + <DEL> keys.
b Click Task Manager.
c Click on the Performance tab.
d Click on the Ethernet connection for the Sonar Head.

5 Make sure the activity on your local network is as expected.
a Allow the system to run for a few minutes to plot the Throughput graph.

Getting started
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b Observe the graph to determine the average network link speed.

An average link speed of at least 80 Mbps is required by most sonar
applications (some applications and range scales will use less). A link speed of
less than 80 Mbps may result in a slower than expected ping rate.

c Right-click in the Throughput graph and select View network details.

Observe that the Network Details window opens.
d Confirm that the Network utilization is at least 80%.

Note

If the Network utilization is less than 80%, disconnect the sonar, close all other
programs, then reconnect the sonar. In general, make sure that your network
environment supports the required link speed.

e In the Flexview software, look for any messages in the Output Messages
window.

Make sure there are no lost packets.

Tip

The contents of the Output Messages window are also saved to a file in the
folder C:\KML\Flexview_V0131\LOGS.

f If you see missing pings, try reduce the value in the Override Network Link
Speed box to improve the performance.

Flexview Reference Manual
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Operating procedures

Topics
Setting up and running the sonar, page 28

Saving and recalling screen captures, page 46

Using sonar view overlays, page 56

Configuring the Sonar Head, page 62

Operating procedures
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Setting up and running the sonar

Topics
Starting operation of the Sonar Head, page 29

Configuring your preferences, page 30

Choosing the sonar range, page 31

Choosing a sonar application, page 32

Adjusting the sonar view, page 33

Applying filters, page 36

Adjusting the TVG (Time Variable Gain) setting, page 36

Setting up external sensors, page 37

Defining a custom sensor, page 40

Controlling the rotator, page 43
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Starting operation of the Sonar Head
To start operation of the Flexview sonar, you may need to make sure that the Sonar
Head has been discovered.

Prerequisites
• The Flexview software must be running.
• The sound speed has been entered in

Setup→System Configuration→Deployment→Master Reference.

Procedure
1 Click Setup→Connect to start the Sonar Head.
2 If you see an error in the Output Messages window, make sure that the Sonar Head

has been discovered.
a Click Setup→System Configuration→Devices→Sonar Setup.
b Click Discover Sonar Heads to search for the sonar on the network.

c If the Sonar Head is found, select it, then click Use Discovered Head.

A discovered Sonar Head appears in the Online Sonar Heads list. If the Sonar
Head does not appear, the Ethernet connection between the Sonar Processor
and Sonar Head has not been established.

d Click Close.

Related topics
System Configuration dialog box - Sonar Setup page, page 113

Operating procedures
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Configuring your preferences
You may wish to set up the system preferences to use measurement units appropriate to
your location, or to choose a preferred save location for your recorded sonar data.

Context

The Preferences dialog box is used to set up system preferences such as units of measure,
time format, etc. This dialog box also allows you to select the save location for
screenshot images and recorded sonar data files.

Procedure
1 Click Setup→Preferences.
2 Choose the unit of measurement for all the readouts related to range and distances

in the Flexview system user interface.
3 Choose whether you would like to display the range and bearing or X and Y

coordinates of your mouse cursor position.
4 Fill out the Overlay Text boxes if you wish to display information on your

screenshots and data recordings.
5 Choose your desired File Saving settings.
6 Select Close to save the chosen settings and close the dialog box.

Related topics
Preferences dialog box, page 105
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Choosing the sonar range
The Range function allows you to specify the maximum theoretical vertical depth and
horizontal distance covered by the Flexview.

Context

The Flexview Sonar Head can operate at different predefined near and far
ranges.

The range value is defined from the Sonar Head.

Note

You cannot change the range until the Sonar Head is connected.
Right-clicking in the sonar view and the range slider bar will both be
disabled until the sonar is running.

Procedure
1 Click Setup→Connect to start the Sonar Head.
2 Right-click inside the sonar view to display the range menu.

3 Select the desired near and far range from the menu.

Tip

You can change the units of measurement in the Preferences dialog box.

4 You can increase or decrease the range using the range slider bar to
the left of the sonar view.

Click the top arrows to increase or decrease the far range.
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Tip

Even though you can choose a large range value, that does not mean that you can
detect your targets on the same range. The range value only defines the range that
is shown in the views. Actual target detection will always depend on the operational
environment, such as water temperature, salinity, interference and layers in the
water column.

Result
The range is displayed with measured intervals in the sonar view. The current range will
be updated when the Sonar Head is running.

Choosing a sonar application
Choosing an appropriate sonar application can improve the quality of your data.

Context
Note

You cannot select a sonar application until the Sonar Head is connected. All Sonar
Applications menu items will be greyed out until the sonar is running.

The Sonar Applications menu lists various operating modes used for different
applications. Each mode has its own pre-defined characteristics, such as differing ranges,
angular resolutions, and pulse types.
If you don’t see the sonar application that you need in the menu, you may need to add it
to the list. You can configure which applications will appear by opening the Customize
Apps dialog box, which is the last item in this list.
Tip

Each sonar application has its own TVG profile. Before changing the TVG settings,
start the sonar (click Setup→Connect), then select the sonar application you want to
configure from the Sonar applications list. Click the TVG button. This button is located
on the tool bar.

Procedure
1 Click Setup→Connect to start the Sonar Head.
2 Select Sonar Apps from the menu on the top bar.
3 Select an appropriate sonar application from the list.

a If you wish to gather imaging data, select an imaging sonar application from
the list.
We recommend a maximum vessel speed of five knots for imaging applications.
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Note

For high-quality images at a short range, use one of the EIQ modes (500-kHz
transducer only) or Imaging Enhanced (available on frequencies from 700-kHz
to 1400-kHz). We recommend a maximum vessel speed of two knots for EIQ
mode and 0.5 knots for EIQ - Fine mode.

b Select one of the test apps to troubleshoot performance issues.

Related topics
Sonar Applications menu, page 82

Adjusting the sonar view
All echo information offered by the Flexview is shown in the sonar view.

Context

The Display Widget allows you to adjust the filter strength, change the display gain, and
choose your echo colours. You can drag sliders with the mouse to increase or decrease
parameter values. For fine adjustments, use the mouse scroll wheel to move the slider
by one increment.

Note

If you have a high-frequency Flexview transducer, you can change the frequency using
the Display Widget.

The Display menu allows you to configure a number of options in the sonar view,
including making the sonar view full screen and adjusting the annotations, palette, or
sector orientation. Functions to improve image quality, such as a speckle filter and
automatic sidelobe reduction, are also available in the Display menu.

Tip

You can change the physical size of the sonar view by clicking on the left view border,
then dragging it to create a smaller or larger window. You can also make the sonar view
full screen by clicking Display→Full Screen or by clicking the Show Full Screen button
in the tool bar.
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Procedure
1 Use the Display Widget to adjust the sonar view according to your preferences.

a Click the Display Widget icon.
This icon is located in the
lower-right corner of the sonar
view.

b If you have a high-frequency
transducer, click one of the
buttons to select a frequency (in
kHz).

The frequency buttons will not
appear if you are using a 500
kHz transducer.

c To adjust the strength of an
enabled filter in the sonar view
(such as Average Filter or Edge
Enhancement), drag the Filter
slider to increase or decrease the filter effect.

Note

The Filter slider will not appear if no filters are enabled. Note that filter
settings will not be saved when the software is closed.

d To adjust the display gain manually, check the box and drag the Gain slider to
increase or decrease the gain.

Display Gain controls the "amount" of echo that is displayed, in other words
the "strength" or "intensity" of the echo presentation. Uncheck the box if you
want the software to adjust the gain automatically.

Note

Adjusting the display gain manually will disable the Sidelobe Reduction
function (found in the Display menu).

e Drag the Contrast slider to increase or decrease the sonar view display contrast.
f To choose your echo colours, right-click on the Palette bar to cycle through the

colour scale options.

Which colour scale to use is mainly a personal preference based on ambient
light conditions, the nature of the echoes and your own experience.

g Click the Display Widget icon to hide the widget.
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2 Use the Display menu to control the visual aspects of the system, and to show or
hide various elements in the presentation.
a Click Full Screen to make the sonar view

full screen.

Press the Esc key to exit full-screen mode.
b Click Annotations to enable or disable the

bearing and range annotations in the sonar
view.

c Select Font Size to increase or decrease the
size of the annotations in the sonar view.

d Select Palette to choose your preferred
echo colours. Which colour scale to use
is mainly a personal preference based on
ambient light conditions, the nature of the
echoes and your own experience.

e Select Sector Orientation to choose a
different angle of orientation for the sonar
view. Enter an angle (in degrees) into the
Orientation dialog box, then click Apply to
rotate the sonar view to your chosen angle.

f If your Sonar Head is forward looking,
click Heading Overlay to enable or disable
this feature. When this feature is enabled,
the degree annotations in the sonar view
will change to reflect the current sonar
heading.

g Click Speckle Filter to enable or disable this function. This filter reduces noise
(the grainy “salt-and-pepper” pattern) in uniform areas of the sonar view.
Distinguishable details in features and targets will be retained.

h Click Sidelobe Reduction to enable or disable automatic sidelobe reduction.
This function improves overall image quality by reducing the sidelobes of
strong targets.
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Applying filters
You can apply an averaging, background removal, or an edge enhancement filter to
the sonar view.

Context

These buttons are located on the tool bar.

Procedure
1 Click one of the filter buttons.

Observe the changes in the sonar view.
2 Increase or decrease the filter effect.

a Click the Display Widget icon.

This icon is located in the lower-right corner of the sonar view.
b Drag the Filter slider to adjust the strength of the filter.

3 Click the No Filter button to turn off all filters.

Related topics
Filters, page 158

Adjusting the TVG (Time Variable Gain) setting
You can adjust the time variable gain for each sonar application in the TVG Setup dialog
box.

Context

TVG (Time Variable Gain) compensates for the loss of acoustic energy due to geometric
spread and absorption.

Procedure
1 Click Setup→Connect to start the Sonar Head.
2 Select the sonar application you wish to configure from the Sonar applications list

on the top bar.

Tip

Each sonar application has its own TVG profile.

Flexview Reference Manual



922-20207001/1.3 37

3 Click the TVG button.

This button is located on the tool bar.
4 Drag the sliders to adjust the A, B, C, and L Factors.

Click the arrow buttons to make small adjustments.
5 Click Apply to save the settings.

Note

The TVG profiles will not be saved when closing the software — default values will
apply when starting up the Flexview software.

Related topics
TVG Setup dialog box, page 155

Setting up external sensors
If you wish to add external sensors (such as a GPS to provide navigation information)
to your system, you will need to add them on the Sensors Setup page. You will also
need to set the sensor properties so that the Flexview software communicates properly
with your sensor.

Prerequisites

Make sure that your external sensors are installed and physically connected to the
Flexview system with the proper cables.
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Procedure
1 On the Sonar Processor desktop, double-click the Flexview icon to start the

software.
2 Click Setup→System

Configuration→Devices→Sensors
Setup.

3 Configure your external sensors in the
dialog box.
a Click Add Device.
b Select the type of sensor you

are using from the Protocol
drop-down list.

Note

In most cases, you can select
a standard NMEA datagram for
your sensor type. For example,
select HDT for your vessel
heading sensor, or GGA for your
GPS position sensor.

c Click in the Name field and enter
a label for the sensor (for example, Hemisphere VS330).

d Configure the serial port settings for the sensor by selecting the correct values
from the drop-down lists.

4 Test each sensor to make sure that the NMEA string is being received by the
Flexview software.
a Select each sensor device and click the Test Device button.
b Make sure that the NMEA sensor string is being displayed in the Port Monitor

box.
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c Click Stop Test when done.
5 Make your external sensors a Master

Reference.
a Select the Deployment→Master

Reference tab.

On the Master Reference page,
you can assign any external
sensors you have set up as the
primary source for various types
of navigational data.

b Select the sensor that you set
up earlier from the drop-down
list beside the appropriate Master
Reference parameter.

You should see the name in the
drop-down list that you assigned earlier (in the Name field on the Sensors
Setup page).

Tip

When using the Flexview for imaging, set up sensors for Position and Heading
if you want to create GeoTiff files or create a real-time mosaic.

6 If necessary, configure the Mounting
Offsets.

Note

You will only need to configure
the Mounting Offsets if you set up
a position sensor (such as a GPS
antenna) in the previous steps.
Inaccurate mounting offsets will
display your sonar data incorrectly
in the sonar view.

a Select the Deploy-
ment→Mounting Offsets tab.

b Measure and record the position
and angle of the Sonar Head
transducer (centre of the face)
relative to your position sensor.

c Enter the X, Y, and Z offsets, as well as the Pitch Roll, and Yaw angles that
you measured earlier into the Value fields.
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d Select the correct Orientation from the drop-down list.

Match the orientation to the physical installation of your Sonar Head. For
example, if the transducer face is facing forwards for ROV navigation, select
Forward.

Defining a custom sensor
You will find many supported sensor formats in the Protocol drop-down list found on
the Sensors Setup page in the System Configuration dialog box. However, if a particular
third-party sensor format is not listed there, you can create it (using the third-party
sensor specification as your guide).

Context

The Define Custom Sensor dialog box allows you to import sensor strings from third-party
sensors or ROV systems. The configuration wizard in this dialog box will guide you
through the process.

This dialog box is opened from the Setup menu.

Procedure
1 Click Setup→Define Custom Sensor.

Observe that the Define Custom Sensor dialog box opens.

Flexview Reference Manual



922-20207001/1.3 41

2 Enter in the Message ID.

The start (prefix) of the sensor sentence. Refer to the manufacturer's sensor
specification to determine what to use. For example, “:” or “$GPRMC”.

3 Select one or more delimiters.

The character used to separate each string in the sentence. You can select more
than one if necessary - each character will be treated as one delimiter. Refer to the
manufacturer's sensor specification to determine what to use.

4 Select the correct termination character.

The ASCII character that tells the software where the sensor string ends. Options
include a carriage return (CR), line feed (LF), or both. Refer to the manufacturer's
sensor specification to determine what to use.

5 Enter in the sensor format.

For example: “: ALT DEP HDG ROL PIT” defines a sensor sentence with the
Message ID “:” and five fields for Altitude, Depth, Heading, Roll, and Pitch
separated by space delimiters.
a Enter the Message ID, followed by the chosen delimiter.
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b Enter in one or more of the three-letter definition strings from the list on the
right side of the dialog box.

Match each three-letter string with the data type in the sensor specification.
For example, enter "ALT" for the part of the sensor sentence corresponding
to Altitude, and so on.

c Separate each string with the chosen delimiters.
d If you can't find any part of the sensor sentence on the right-side list, then

enter the "Ignored field" string (III).

This will tell the software to skip over this part of the sensor sentence when
parsing the string.

6 Select Next to continue.

7 Provide specifications for each three-letter definition string you entered into the
Sensor Format field.
a If applicable, select a data type.

If the data type in the sensor sentence is an integer (for example, 1002), then
select Whole number. If the data type in the sensor sentence is a float (for
example, 10.02), then select Decimal number. Refer to the manufacturer's
sensor specification to determine what to use.

b If applicable, select a Latitude/Longitude Format.

Choose whether to display the latitude/longitude format in degrees, degrees
and minutes, or degrees, minutes, and seconds.

c If necessary, enter in a unit scale factor.

The dialog box will tell you what unit scale the software expects (meters,
degrees, meters per second, and so on). If the data type in the specification
does not match the required unit scale, you must enter an appropriate scaling
factor. For example, if the Depth data type is in feet, then you must enter
0.3048 to scale the depth value to meters.
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8 Select Next to continue.

9 Enter in a unique name for your custom sensor.

This name will appear in the Protocol drop-down list found on the Sensors Setup
page in the System Configuration dialog box.

10 Select Finish to close the wizard.
11 Set up the custom sensor in the software to start using it.

a Click Setup→System Configuration→Devices→Sensors Setup.
b Click Add Device.
c Give the sensor a name, then select the custom sensor from the Protocol

drop-down list.
d Select the Deployment→Master Reference tab.
e Select the sensor that you set up earlier from the drop-down list beside the

appropriate Master Reference parameter.

Tip

To change or remove the custom sensor, edit or delete the custom
sensor XML file. You can find the custom sensor XML file in
C:\KML\Flexview_V0131\BIN\DefinedSensors.

Related topics
Define Custom Sensor dialog box, page 100

Controlling the rotator
You can control your rotator(s) with the Rotator Control dialog box.

Prerequisites
• You must set up your rotator(s) by clicking Setup→System Configura-

tion→Devices→Rotators Setup.
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• If necessary, configure your rotator axis offsets relative to the sonar by clicking
Setup→System Configuration→Deployment→Mounting Offsets.

• This dialog box will only appear if the sonar is running.

Context

If you have more than one rotator installed, then one dialog box for each rotator will
appear.

The controls you see will depend on the type of rotator you have and which control
type you have selected.

Single-axis rotator with Pan/Tilt controls:
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Dual-axes rotator:

Procedure
1 Click Setup→Connect to start the Sonar Head.

Observe that the Rotator Control dialog box opens.
2 Click Connect to enable the rotator controls or Disconnect to disable the rotator

controls.
3 If you have a Kongsberg 806-00360000 rotator, click the Calibrate button.
4 If you are using Pan and Tilt controls, click the arrow buttons to move the Sonar

Head.

If you have a single-axis rotator, the arrow buttons will either pan or tilt, depending
on the orientation of the rotator installation.

Tip

Drag the slider to control the rotator speed.

Related topics
Rotator Test dialog box, page 122
System Configuration dialog box - Mounting Offsets page, page 129
System Configuration dialog box - Rotators Setup page, page 119
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Saving and recalling screen captures

Topics
Saving and retrieving images, page 47

Recording sonar data, page 47

Playing back a recording, page 48

Converting your recording format, page 49

Converting your recordings to video, page 51

Saving GeoTiff files, page 53
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Saving and retrieving images
With one click, you can capture an image of the sonar view — either with overlays
or without overlays.

Prerequisites

Open the Preferences dialog box to change the default save location, choose your own
filename, and add overlay text.

Procedure
1 Click the Save image with overlay button.

If you want to save the sonar view without overlays, click the Save
image without overlay button instead.

These buttons are located on the tool bar.

Note

A “Save As” dialog box will appear if you have checked the Prompt User for
Filename box in the Preferences dialog box.

2 Retrieve your images and view them.
a On the Windows Taskbar, click the File Explorer shortcut.

Alternatively, press Win + E to open the File Explorer.
b Click This PC.
c Navigate to C:\KML\Flexview_V0131\Images.

Alternatively, navigate to where you saved your images earlier.
d Open the images with your preferred image viewer..

Recording sonar data
You can record a sonar data sequence and save it in a time-stamped digital format. You
can also re-record data during playback to capture a smaller clip of the data set.

Prerequisites
• Open the Preferences dialog box to change the default save location, choose your own

filename, and add overlay text.
• Click File→Recording Format to choose between recording raw sonar data (to a

“.mmb” file) or recording beamformed sonar data (to a “.imb” file).

Procedure
1 Click the circular icon in the top-right corner of the sonar view to open the Menu

Widget.
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2 Click Record Data or press F4 to start recording.

When recording is in progress, a flashing recording icon will appear in the top-right
corner of the sonar view. The recording filename will also appear here. Observe the
percentage of disk space free for recording on the far right of status bar.

Note

A “Save As” dialog box will appear if you have checked the Prompt User for
Filename box in the Preferences dialog box.

3 Click Stop Recording or press F4 when you are done.

Your recording will be saved under the folder
“C:\KML\Flexview_V0131\Recordings” by default. You can change this save
location in the Preferences dialog box.

Related topics
Recording Format, page 88

Playing back a recording
You can play back a previously recorded data file to view the sonar image sequence
captured during operation of the Sonar Head.

Prerequisites

Open the Preferences dialog box to change the default save location, choose your own
filename, and add overlay text.

Tip

When the Flexview software isn’t running, double-click on a recording file to open the
software and begin playback automatically.

Procedure
1 Click File→Playback.

A file browser dialog box opens to let you choose which file to play back.
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2 Select the file you want to play back and click Open.

Playback will begin. The Playback Console will automatically open to offer you
additional functionality.

3 Control playback using the Playback Console.

You can stop, pause, fast forward, or advance through the recording one ping at a
time. You can also repeat playback of the file on a never-ending loop.

Tip

You can also apply filters to the playback, such as the Average or Edge Enhancement
filters.

4 When you are done, click the Stop button on the Playback Console, then close the
console.

Alternatively, click File→Stop Playback.

Related topics
Convert to Video Format dialog box, page 88
Playback Console, page 98

Converting your recording format
If you want to keep your recordings in .mmb format but process your data in .imb format,
you can convert .mmb files to .imb files using a batch conversion utility.

Context

The Flexview software records sonar data in two formats — raw element data (.mmb) or
beamformed data (.imb).

If you wish to convert a selected clip of data, you can play back an .mmb file and record
the clip as an .imb file. However, if you wish to batch convert many files, a conversion
utility is provided with the Flexview software.

Note

If files are recorded in .imb format, they cannot be converted to .mmb.

You can find the conversion utility in the folder
C:\KML\Flexview_V0131\bin\M3Converter.exe.
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Procedure
1 Select Recording File to convert a single .mmb recording.

Alternatively, select Recording Folder and Include Subdirectories to convert all
your .mmb files.

2 Click the Browse button beside Source to select your .mmb file or folder.
3 Click the Browse button beside Destination to select where you want to save the

converted files.

If you are saving a single recording, then you must give the file a name.

Tip

When converting the contents of a folder, the files will automatically be renamed.
However, we recommend selecting different source and destination folders to avoid
filename duplications.

4 Click Convert.

A dialog box will notify you when the file conversion is complete. Click OK
to dismiss it.

Flexview Reference Manual



922-20207001/1.3 51

Related topics
Recording Format, page 88

Converting your recordings to video
As data files can only be opened by the Flexview software, converting data files to video
allows you to share them more easily with others.

Context

The Convert to Video Format dialog box allows you to convert an MMB or IMB file to
a video file (MP4 format only).

Use this dialog box if you want to export a recording to a format that is playable by
any media player. This function is useful if you wish to share recordings with others
who do not have the Flexview software installed on their computers, or if you wish to
upload your recording to an online service.
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Procedure
1 Click File→Convert To Video.

Observe that the Convert To Video Format dialog box opens.
2 Select the desired video conversion settings.
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3 To convert a single data file, select the Source File button and use the browser
window to select the file.

To batch convert all sonar recordings in a selected folder, select the Folder
Conversion checkbox, then select the Source Folder button to select the folder in the
browser window.

Note

If you select this option, you will not be able to change the name of the converted
files. Auto Name will be selected under the Target file naming convention drop-down
list and the other options will not be available.

4 Click the Convert button to start the conversion.
5 Wait until the progress bar is complete before viewing the videos.

If you are performing a batch conversion, an additional progress bar will appear at
the bottom of the dialog box to show you how many files are being converted.

Related topics
Convert to Video Format dialog box, page 88

Saving GeoTiff files
GeoTiff files are TIFF files which have geographic data embedded within them. The
geographic data can then be used to position the image in the correct location and
geometry on the screen.

Prerequisites
• You must have a position and heading sensor connected to your system and

sending data to the Flexview software. To add sensors, click Setup→System
Configuration→Devices→Sensors Setup.

• Your Master Reference must be set up to use the sensor inputs or to use a fixed
location by entering Latitude, Longitude, and Heading. To set up the Master
Reference, click Setup→System Configuration→Deployment→Master Reference.

• Your mounting offsets must be configured correctly. To configure your mounting
offsets, click Setup→System Configuration→Deployment→Mounting Offsets.

• You must be using the appropriate coordinate system for your current location. To
choose your coordinate system, click Setup→Geo Projection.
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Context

GeoTiff files contain georeferencing information and can be opened in third-party
software, such as Google Earth Pro.

Procedure
1 Click Setup→Preferences.
2 Fill out the fields in the GeoTiff Auto Save section.

a To automatically save a GeoTiff file every set number of meters, select
Distance and enter a value. To automatically save a GeoTiff file every set
number of seconds, select Time and enter a value.

b To save a cropped GeoTiff image for mosaicking purposes, enter the
percentage to crop.

3 Press F11 to enable or disable GeoTiff auto save. The status bar will display
“GeoTiff” in green when auto save is enabled.

When GeoTiff autosave is enabled, GeoTiff files will be saved automatically and
continuously based on travel distance or time.
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Alternatively, press F10 to save a single GeoTiff file to your images folder. Your
images will be saved under the folder “C:\KML\Flexview_V0131\Images” by
default. You can change this save location through the Preferences dialog box.

Related topics
System Configuration dialog box - Sensors Setup page, page 116
System Configuration dialog box - Master Reference page, page 126
System Configuration dialog box - Mounting Offsets page, page 129
Geo Projection dialog box, page 103
Preferences dialog box, page 105
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Using sonar view overlays

Topics
Measuring distances, page 57

Measuring angles, page 58

Defining an area, page 58

Placing text labels, page 59

Placing reference cursors, page 60

Placing target markers, page 61
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Measuring distances
You can use the tape measure tool to draw a line in the sonar view and measure the
distance between two points.

Context

Measures distances on the sonar view. Also allows you to place a measurement overlay
on the sonar view.

Procedure
1 Click the Tape Measure button.

This button is located on the tool bar.
2 Click and hold the left mouse button on your first target, then drag the

mouse to your second target.

The length and bearing between the targets is displayed dynamically.

Note

The measurement line will not remain on the display when you release the mouse
button.

3 To keep the measurement line on the display, place a measurement overlay.
a Click and hold the right mouse button on your first target.
b Drag the mouse to your second target and release the mouse button.
c Move the mouse to a place on the screen where you would like to place the

overlay length and bearing label.

Note

Once the measurement overlay is placed, you can use the default arrow cursor
to drag the length and bearing label to a position on the screen where it
is more legible.

d Click the left mouse button to place the overlay.

Tip

To remove this overlay, click theWiper button, then click the overlay.

Related topics
Tape Measure, page 151
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Measuring angles
You can use the protractor to measure the angle between two lines, then place the
resulting overlay in the sonar view.

Context

The protractor tool measures the angle between a baseline and a second line that
intersects the baseline.

Procedure
1 Click the Protractor button.

This button is located on the tool bar.
2 In the sonar view, click the point where you want to start the baseline.
3 Click the point where you want to end the baseline.

The second line will appear.
4 Lock one end of the second line to the baseline.

a Choose where you want the second line to intersect the baseline by moving the
mouse along the length of the baseline.

b When ready, click the left mouse button.
5 Choose where you want the second line to end.

a Move the mouse to any point on either side of the baseline to adjust both the
length and angle of the second line.

b Click the left mouse button to place the overlay.

Tip

To remove this overlay, click theWiper button, then click the overlay.

Related topics
Protractor, page 152

Defining an area
You can use the string measure tool to define an area. The size and perimeter of the
area will be calculated for you.

Context

Defines and measures perimeters and areas. Allows you to place an area overlay on
the sonar view.
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Procedure
1 Click the String Measure button.

This button is located on the tool bar.
2 Click anywhere in the sonar view to start a point.
3 Move to the second point, then click again.
4 Click as many times as necessary to create the required area.
5 Double-click on the last point to finish.

The area will automatically be closed, and a rectangular label will appear providing
information about the area and perimeter.

6 Move the label to a position on the screen where it is most legible, then click the
left mouse button to place it.

Tip

To remove this overlay, click theWiper button, then click the overlay.

Related topics
String Measure, page 152

Placing text labels
The text label tool allows you to place comments on the screen.

Prerequisites

Text labels will not appear on sonar data recordings. To place a text overlay on a
recording, click Setup→Preferences and fill out the Overlay Text boxes.

Procedure
1 Click the Text Label button.

This button is located on the tool bar.
2 In the sonar view, click the area of interest that you want to label.
3 Click and hold the left mouse button on the label overlay and drag it to a place

on the screen where the text is legible.
4 Label the area of interest.

a Double-click on the label overlay to open an Edit Text Box dialog box.
b Enter the desired text into the dialog box.
c Click OK when done.
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5 If the text you entered does not fit within the text label overlay, you can resize the
label by clicking on the label border, then dragging it to create a larger label.

Tip

To remove this overlay, click theWiper button, then click the overlay.

Related topics
Text Label, page 152

Placing reference cursors
You can place one or two reference cursors as overlays on the sonar view. When you
place two cursors, an additional overlay will appear with information about the cursors.

Context

The Reference Cursor buttons are used to mark points of interest and to
determine the range and bearing of these points (relative to the Sonar Head).

These buttons are located on the tool bar.

Procedure
1 Click the Reference Cursor 1 button.
2 Move the mouse to where you want to place the cursor.

Tip

To make fine adjustments to the cursor position, drop a reference cursor into a
Zoom window.

3 Click the left mouse button to place the cursor as an overlay in the sonar view.

The range and bearing of the cursor’s position — relative to the Sonar Head — is
shown in the bottom-left corner of the view.

4 Click the Reference Cursor 2 button.
5 Move the mouse to where you want to place the cursor.
6 Click the left mouse button to place the cursor as an overlay in the sonar view.

The range and bearing of the cursor’s position — relative to the Sonar Head — is
shown in the bottom-left corner of the view. “Delta” shows the range and bearing
from cursor 1 to cursor 2.

Tip

To remove this overlay, click theWiper button, then click the overlay.
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Related topics
Reference cursors, page 153

Placing target markers
The Target Marker function is primarily used for remotely operated vehicle (ROV)
navigation. Third-party ROV software can use the time and location information to
steer the ROV toward the target.

Context

You can press 0–9 to place a marker in the sonar view that is stamped with time and
location information. In addition, you can export this information to a serial or UDP port.

Procedure
1 To start using target markers, click Display→Enable Target Marker.

Observe that the Target Marker Export dialog box opens.
2 Choose a serial port from the drop-down list.

Note

The default serial settings cannot be altered.

3 Click OK to enable serial port export.

Alternatively, click Cancel to use the Target Marker function without exporting to
a serial port.

UDP export is always available, whether you enable serial port export or not.
4 Move the mouse cursor to the location in the sonar view where you wish to place

a marker.
5 Press any number key from 0 to 9 on your keyboard to place a marker.

Note

Target markers cannot be moved once they are placed.

6 To remove all target markers from the sonar view, click Display→Delete All
Markers.

Alternatively, use the wiper located on the tool bar to remove individual markers.

Related topics
Target Marker Export dialog box, page 96
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Configuring the Sonar Head

Topics
Upgrading the Sonar Head, page 63

Changing the Sonar Head IP Address, page 65
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Upgrading the Sonar Head
The Sonar Head has both software and firmware. You can upgrade these with the latest
versions obtained from Kongsberg Mesotech. You can also use this same procedure to
downgrade software and firmware versions.

Prerequisites

If you are performing a full upgrade, you will need to write three files to the Sonar Head
before power cycling the unit:
• The Sonar Head software file (.ASW)
• The Sonar Head transmit firmware file (.TXF)
• The Sonar Head receive firmware file (.RXF)

You can download these files from our website.

• https://www.km.kongsberg.com/mesotechsoftware

Context

The Head Firmware Configuration dialog box allows you to upgrade the Sonar Head
firmware. This dialog box is only available when the Sonar Head is connected and
paused.

Procedure
1 Click Setup→Connect to start the Sonar Head.
2 Open the Head Firmware Configuration dialog box.

a Click the circular icon in the top-right corner of the sonar view to open the
Menu Widget.

b Click Pause.
c Click Setup→Head Firmware Configuration.

Observe that the Head Firmware Configuration dialog box opens.
3 Take note of the current versions of software and firmware (Rx HW, Rx SW, Tx

HW, and Tx SW).

The version numbers are listed in the Head Firmware Configuration dialog box.
4 Write the latest firmware and software to the Sonar Head.

a Select Head Application Software under Configuration type.
b Click the file folder icon under Configuration file to browse and select the

.ASW file on your local drive.

Tip

Use the .ASW file with the same version as the .RXF file.

Operating procedures
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c Click Write.

Observe that a confirmation dialog box opens.
d Click Yes to start the upgrade.

Tip

If you click Cancel or Stop, the upgrade process will be aborted. The Sonar
Head software and firmware will not be changed.

e Select RX FPGA Configuration (receive firmware) under Configuration type.
f Click the file folder icon under Configuration file to browse and select the .RXF

file on your local drive.
g Click Write, then click Yes to start the upgrade.

Note

This file may take a few minutes to program.

h Select TX FPGA Configuration (transmit firmware) under Configuration type.
i Click the file folder icon under Configuration file to browse and select the .TXF

file on your local drive.
j Click Write, then click Yes to start the upgrade.

Note

This file may take a few minutes to program.

k Close the Head Firmware Configuration dialog box.
5 Confirm the upgrade was successful.

a Click Setup→Disconnect.
b Disconnect the power to the Sonar Head, then power it up again.
c Wait ten seconds for the software to discover the Sonar Head.
d Click Setup→Connect to start the Sonar Head.
e Click Setup→Head Firmware Configuration.

Observe that the Head Firmware Configuration dialog box opens.
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f Confirm that the software and firmware has been upgraded from the versions
you took note of earlier.

Note

The receive hardware (RX HW) and software (RX SW) must both be on the
same version. In other words, the application software (.ASW) and FPGA RX
Firmware (.RXF) files being upgraded must have the same version numbers.
The Sonar Head will make sure the versions are the same. If not, the version
numbers shown in the Head Firmware Configuration dialog box will not be
updated.

Related topics
Head Firmware Configuration dialog box, page 111

Changing the Sonar Head IP Address
If you have a unique network environment (such as an IP Address conflict between two
devices on your network), or you are installing a second Sonar Head, then you will need
to change the IP Address of the Sonar Head.

Context

The Head Network Setup dialog box allows you to change the Sonar Head network
parameters, such as the IP address. This dialog box is only available when the Sonar
Head is connected and paused.

You can program the IP address and the IP port of the Sonar Head for various network
environments. The factory default IP address is 192.168.1.234, and the default port
number is 30.

Procedure
1 Set up the Sonar Head and Flexview software.

a Connect the Sonar Head directly to the computer network card. Do not connect
through an intermediary device, such as a network switch or router.

b Power up the Sonar Head.
c Double click the Flexview icon on the desktop to run the Flexview software.
d Click Setup→Connect to start the Sonar Head.
e Click the circular icon in the top-right corner of the sonar view to open the

Menu Widget.
f Click Pause.

2 Write the new IP Address to the Sonar Head.
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a Click Setup→Head Network Setup.

Observe that the Head Network Setup dialog box opens.
b Click Read from Head to refresh the fields in the Head Network Setup table.
c Enter the new IP Address in the table.

Tip

Avoid setting the third octet of the IP Address to a value of 100 or more, as you
may experience periodic drops in traffic. We recommend leaving the third octet
set to the default value (1). For example, xxx.xxx.1.xxx.

d Click Write to Head.

Observe that a confirmation dialog box opens.
e Click Yes to confirm.

Wait for the write operation to complete.
f Close the Head Network Setup dialog box.

3 Click Setup→Disconnect.
4 Apply the new IP Address to the Sonar Head.

a Power off the Sonar Head for three seconds, then power it back up.
b If necessary, change the computer’s network adapter address to place it on

the same network as the Sonar Head.
c Click Setup→System Configuration→Devices→Sonar Setup.
d Click the Discover Sonar Heads button.

The Sonar Head with its updated IP Address should appear in the Online Sonar
Heads table.

e Select the Sonar Head in the Online Sonar Heads table, then click the Use
Discovered Head button.

f Close the System Configuration dialog box.
5 Click Setup→Connect to start the Sonar Head.

Related topics
Defining the IP address on the computer's network adapter, page 21
Head Network Setup dialog box, page 109
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User interface

Topics
Presentation overview, page 68

The Flexview software menu system, page 70

Sonar view, page 71

Tool bar description, page 73

Status bar, page 75
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Presentation overview
By default, the display presentation covers the entire screen.

This Flexview screen capture shows you a typical data replay situation.

The presentation provides you with a lot of information. The sonar view presents sonar
echo data. The menu system on the top gives you easy access to all the functionality
offered by the Flexview software. The tool bar provides buttons for functions, filters,
and sonar view overlays. The bottom Output Messages window and bottom status bar
provide diagnostic messages.

You can resize a window by clicking on the window border, then dragging it to create a
smaller or larger window. Click the pin icon on the window title bar to auto hide the
window. To show the window, hover your mouse over the labelled tab that appears
on the side of the presentation.
A Menu system

The menu system is located on the top of the presentation. To open any of the
menus, click the menu title.

B Range slider bar

When the sonar is running, you can increase or decrease the range using the range
slider bar to the left of the sonar view. Click the top arrows to increase or decrease
the far range.

C Output Messages

The Output Messages window displays information, diagnostic, and error messages.
There are two tabs in this window: one for host messages and one for head
messages.
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D Sonar view

All echo information offered by the Flexview is shown in the sonar view.
E Tool bar

The tool bar provides access to useful functions, such as the ability to take a
screenshot or change your TVG settings. In addition, several measuring tools are
available.

F Information Widget

The Information Widget displays sonar pulse details as well as vessel speed, sound
speed, heading, and latitude/longitude coordinates from external sensors.

G Menu Widget

The Menu Widget provides controls to record data, play or pause playback, and
configure the grid.

H Display Widget

The Display Widget allows you to adjust the filter strength, change the display gain,
and choose your echo colours. If you have a high-frequency Flexview transducer,
you can change the frequency using the Display Widget.

I Playback Console

Control playback using the Playback Console. You can stop, pause, fast forward, or
advance through the recording one ping at a time. You can also repeat playback of
the file on a never-ending loop.

J Status bar

The status bar is located at the bottom of the Flexview presentation. It allows you to
view the system status and disk space. You can also access detailed telemetry info.
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The Flexview software menu system
The menu system is located on the top of the presentation. To open any of the menus,
click the menu title.

To select operational parameters on the Flexview, use the menu system. The menus
are organized in a tree structure. Some of the menu items open dialog boxes to offer
additional choices.

A The File menu allows you to open a recorded file, as well as choose the recording
format of your data files. You can also load your user settings from a previous
software version.

B Use the Display menu to control the visual aspects of the system, and to show or
hide various elements in the presentation.

C You can connect to the Sonar Head using the Setup menu. You can also configure
the system, choose your preferences, set up the coordinate system, upgrade the
Sonar Head firmware, or change the Sonar Head IP Address.

D The Sonar Applications menu lists various operating modes used for different
applications. Each mode has its own pre-defined characteristics, such as differing
ranges, angular resolutions, and pulse types. You can configure which applications
will appear by opening the Customize Apps dialog box, which is the last item in this
list. You cannot select a sonar application until the Sonar Head is connected. All
Sonar Applications menu items will be greyed out until the sonar is running.

E The Advanced menu is intended for experienced users or for testing purposes and is
not required for normal operation of the Flexview. This menu requires a software
license key, and will not appear if you do not have one.

F The Help menu allows you to view hardware and software information in the About
Flexview dialog box. You can also open the Flexview Reference Manual from this
menu.
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Sonar view
All echo information offered by the Flexview is shown in the sonar view.

Description

The range and bearing or X/Y coordinates of the current
mouse cursor position is shown at the bottom of the
sonar view.

Click the icon in the top-left corner of the sonar view to
open the Information Widget. The Information Widget
displays sonar pulse details as well as vessel speed, sound
speed, heading, and latitude/longitude coordinates from
external sensors.

Click the icon in the bottom-right corner of the sonar
view to open the Display Widget. The Display Widget
allows you to adjust the filter strength, change the display
gain, and choose your echo colours.

Right-click inside the sonar view to display the range
menu. You can increase or decrease the range using the
range slider bar to the left of the sonar view.

Tip

You can change the shape of the grid (range rings), or turn it off. Click the icon in the
top-right corner of the sonar view to open the Menu Widget, then click Grid to cycle
through the options.
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You can change the physical size of the sonar view by clicking on the left view border,
then dragging it to create a smaller or larger window. You can also make the sonar
view full screen by clicking Display→Full Screen or by clicking the Show Full Screen
button in the tool bar.

Interpreting the sonar view
The sonar view is a map of the echo returns over the scanned area.

A sequence of colours is used to show the relative strengths of the echo returns. Several
colour scale options are available. Most of them use darker colours to indicate weak
returns, and brighter colours to indicate stronger returns.

Bright spots in the image indicate strong sonar targets. Generally, bright spots indicate
a hard, highly reflective surface. Dark spots in the image indicate either areas of low
reflectivity (soft areas), or possibly an acoustic shadow zone behind a target.

Most targets will block the transmission of sound — either by reflecting it, or absorbing
it. This will leave a shadowed area behind the target that is not ensonified and therefore
will not generate any echoes. This is very similar to the shadow formed when an object is
illuminated with a single light source. The shadow behind a target can often yield more
information about the target than the reflections from the target itself. The shadow will
often reveal the shape of the target, but you must remember that the shape will usually be
distorted according to the position of the Sonar Head relative to the target and the bottom,
and according to the slope of the bottom. It is often possible to estimate the height of a
bottom target based on the length of the shadow and the known height of the Sonar Head.

Noise and interference
Acoustic noise and bubble interference can affect the quality of the sonar view image.

It is usually easy to recognize interference from other acoustic sources such as echo
sounders, pingers, and other sonars. These sources all produce pulses at regularly timed
intervals and will therefore tend to create a regular or symmetrical pattern of blips on the
screen. Mechanical noise sources such as propellers, hydraulic pumps, and thrusters, are
usually more directional and tend to show up only when the sonar is pointed directly
at them.

In addition, sonar signals are easily blocked by air or gas bubbles in the water or on the
transducer face. As an example, the aeration present in the wake of a vessel will often
last for ten to twenty minutes and effectively mask out most sonar returns on the far
side. The aeration partially blocks the outgoing pulses as well as any returns. Another
source of gas bubbles can be found when a sea bottom containing decomposing organic
matter is disturbed by dredging or ploughing.
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Tool bar description
The tool bar provides buttons for functions, filters, and sonar view overlays.

The tool bar provides access to useful functions, such as the ability to take a screenshot
or change your TVG settings. In addition, several measuring tools are available.
A Arrow

Click to use the default arrow cursor. With the default cursor you can select and
manipulate objects on the screen.

B Wiper

Removes items from the sonar view. When selected, click on each overlay you
wish to delete.

C Zoom windows

You can open up to four true zoom windows when running a Sonar Head.
D Tape Measure

Measures distances on the sonar view. Also allows you to place a measurement
overlay on the sonar view.

E Protractor

You can use the protractor to measure the angle between two lines, then place the
resulting overlay in the sonar view.

F String Measure

You can use the string measure tool to define an area. The size and perimeter of the
area will be calculated for you.

G Text Label

The text label tool allows you to place comments on the screen.
H Reference Cursor 1

I Reference Cursor 2

You can place one or two reference cursors as overlays on the sonar view. When
you place two cursors, an additional overlay will appear with information about the
cursors.
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J Image Quality Analysis System

The Image Quality Analysis System (IQAS) analyzes the image quality of a point
target, or can be used to measure a known point target against a specification.

K Y1

Horizontal line overlay that can be used to mark the depth of the natural seabed (for
use when excavating).

L Y2

Horizontal line overlay that can be used to mark the depth of a trenching target (for
use when excavating).

M Show Full Screen

Click Full Screen to make the sonar view full screen. Press the Esc key to exit
full-screen mode.

N Save image with overlays

Click this button to save sonar view images, including any overlays you’ve placed
in the sonar views.

O Save image without overlays

Click this button to save sonar view images, excluding any overlays you’ve placed
in the sonar views.

P TVG Setup dialog box

TVG (Time Variable Gain) compensates for the loss of acoustic energy due to
geometric spread and absorption.

Q Average Filter

Clicking the “A” button will enable the Average Filter. This filter reduces noise.
Slow-moving features persist on-screen.

R Background Removal

Clicking the “B” button will enable the Background Removal filter. This filter
removes stationary parts of the background to enhance moving objects (such as
fish, for example).

S Edge Enhancement

Clicking the “E” button will enable Edge Enhancement. This filter enhances the
edge of moving features.

T No Filter

Disables any filters. The sonar view will display an unfiltered sonar image.
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Status bar
The status bar is located at the bottom of the Flexview presentation. It allows you to
view the system status and disk space. If network logging is enabled, you can view the
sonar connection performance. You can also access detailed telemetry info.

A Recording information

Displays the filename when you are recording data.
B Time synchronization status

Displays the status of the time synchronization process if Host Time Sync
Mode is enabled. “Syncing” displays during time synchronization (which takes
approximately two minutes). “Sync OK” displays when time synchronization is
complete. “Sync Error” displays if the computer clock is irregular (for example,
due to interference from the time source). In this case, restart the synchronization
process by disconnecting, then reconnecting, the Sonar Head.

C Sound Speed

The sound speed is displayed in green (after filtering and thresholding). This text
will display in blue during playback if Override Sound Speed is enabled.

D GeoTiff

If GeoTiffs are automatically being created, then this text will display in green.
E Disk space monitor

Displays the percentage of hard drive space you have available for data recordings.
F System status

Shows the system status, such as “Active” when the system is connected to a Sonar
Head, “Inactive” when not connected, or “Playback” when replaying a recorded
file. Clicking the system status text will open a Connection Status window. You can
click on Flexview Sonar in the Connection Status window to open a Head Status
window showing telemetry information.
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G Sonar connection performance

If network logging is enabled in the System Configuration dialog box, then the ping
loss, packet loss, and the last ping data rate will be displayed.

H Offsets

If Mounting Offsets Override is enabled then this text will appear during playback.

Tip

Right-click on the status bar to configure it. You can show or hide any of the information
displayed here.

Related topics
Recording sonar data, page 47
System Configuration dialog box - Master Reference page, page 126
System Configuration dialog box - Mounting Offsets page, page 129
Saving GeoTiff files, page 53
System Configuration dialog box - Sonar Setup page, page 113
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Menu system

Topics
File menu, page 78

Display menu, page 79

Setup menu, page 81

Sonar Applications menu, page 82

Advanced menu, page 84

Help menu, page 85
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File menu
The File menu allows you to open a recorded file, as well as choose the recording format
of your data files. You can also load your user settings from a previous software version.

How to open

To open this menu, click the menu title.
Description
• Playback

The Playback mode allows you to choose the echo data
file(s) you wish to play back.

• Stop Playback

Clicking Stop Playback will stop the playback of a
recording. You can also use the Playback Console to
control playback.

• Recording Format

Click Recording Format to choose between recording
raw sonar data (to a “.mmb” file) or recording beamformed sonar data (to a “.imb”
file).

• Load User Settings

Click to browse for a “UsersInfo.xml” file (in the folder
C:\KML\Flexview_V0131\bin\SettingsFlexview) from a previous software version.
You can import your previous settings to a new version of the Flexview software.

• Convert to Video

The Convert to Video Format dialog box allows you to convert an MMB or IMB
file to a video file (MP4 format only).

• Exit

Click to close the Flexview software.
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Display menu
Use the Display menu to control the visual aspects of the system, and to show or hide
various elements in the presentation.

How to open

To open this menu, click the menu title.
Description
• Enable Target Marker

Click to enable the Target Marker function.
You can press 0–9 to place a marker in the sonar
view that is stamped with time and location
information. In addition, you can export this
information to a serial or UDP port.

• Delete All Markers

Click to remove all target markers from the sonar
view.

• Full Screen

Click Full Screen to make the sonar view full
screen. Press the Esc key to exit full-screen mode.

• Output Messages window

Click to show or hide the Output Messages
window. The Output Messages window displays
information, diagnostic, and error messages.

• Playback Console

Click to show or hide the Playback Console.
Control playback using the Playback Console. You
can stop, pause, fast forward, or advance through
the recording one ping at a time. You can also
repeat playback of the file on a never-ending loop.

• Rotator Control

Click to show or hide the Rotator Control dialog box for each rotator you have
installed.

• Tool bar

Click to show or hide the tool bar. The tool bar provides buttons for functions, filters,
and sonar view overlays.

• Annotations
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Click Annotations to enable or disable the bearing and range annotations in the sonar
view.

• Font Size

You can choose between using a normal or a large font size throughout the Flexview
software.

• Palette

Select Palette to choose your preferred echo colours. Which colour scale to use is
mainly a personal preference based on ambient light conditions, the nature of the
echoes and your own experience.

• Sector Orientation

Enter an angle (in degrees) into the Orientation dialog box, then click Apply to rotate
the sonar view to your chosen angle.

• Heading Overlay

If your Sonar Head is forward looking, click Heading Overlay to enable or disable this
feature. When this feature is enabled, the degree annotations in the sonar view will
change to reflect the current sonar heading.

• Speckle Filter

Click Speckle Filter to enable or disable this function. This filter reduces noise (the
grainy “salt-and-pepper” pattern) in uniform areas of the sonar view. Distinguishable
details in features and targets will be retained.

• Sidelobe Reduction

Click Sidelobe Reduction to enable or disable automatic sidelobe reduction. This
function improves overall image quality by reducing the sidelobes of strong targets.
Sidelobe reduction is especially useful at short ranges when targets are very close. In
addition, the automatic adjustments work well when the sonar is constantly moving,
such as on an ROV.

Tip

If you have a software license for advanced features, you can view the
automatically-calculated sidelobe reduction ratio or manually adjust the ratio using
a slider.

• Reset to Default Layout

Click to reset the presentation layout. All windows and dialog boxes will be docked
in their default location. In addition, some display elements are hidden by default.
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Setup menu
You can connect to the Sonar Head using the Setup menu. You can also configure the
system, choose your preferences, set up the coordinate system, upgrade the Sonar Head
firmware, or change the Sonar Head IP Address.

How to open

To open this menu, click the menu title.
Description
• Connect

Click Connect to connect to the Sonar Head
and start “pinging”.

Note

When the Sonar Head is running, this menu
command will change to Disconnect.

• Define Custom Sensor

Click to open the Define Custom Sensor dialog box. If the sensor protocol you want to
use is not available on the Sensors Setup page, you can create a custom sensor format
in the Define Custom Sensor dialog box.

• Geo Projection

Click to open the Geo Projection dialog box. You can configure the coordinate system
using the Geo Projection dialog box.

• Preferences

Click to open the Preferences dialog box. The Preferences dialog box is used to set up
system preferences such as units of measure, time format, etc.

• Head Network Setup

Click to open the Head Network Setup dialog box. The Head Network Setup dialog
box allows you to change the Sonar Head network parameters, such as the IP address.
This dialog box is only available when the Sonar Head is connected and paused.

• Head Firmware Configuration

Click to open the Head Firmware Configuration dialog box. The Head Firmware
Configuration dialog box allows you to upgrade the Sonar Head firmware. This dialog
box is only available when the Sonar Head is connected and paused.

• System Configuration

Click to open the System Configuration dialog box. This dialog box allows you to
set up the Sonar Head, external sensors (such as a GPS or Motion Reference Unit),
and rotators. In addition, you can configure the deployment of the Flexview and
enter mounting offsets.
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Sonar Applications menu
The Sonar Applications menu lists various operating modes used for different
applications. Each mode has its own pre-defined characteristics, such as differing ranges,
angular resolutions, and pulse types.

Note

You cannot select a sonar application until the Sonar Head is connected. All Sonar
Applications menu items will be greyed out until the sonar is running.

How to open

To open this menu, click the menu title.
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Description
• EIQ (500-kHz transducer only)

This sonar application captures high-quality images.
At short ranges the images are relatively insensitive
to the motion of the sonar. At longer ranges the
sonar should be relatively motionless.

Note

This application is less sensitive to motion than EIQ
- Fine.

• EIQ - Fine (500-kHz transducer only)

This sonar application captures very high-quality images. At short ranges the images
are relatively insensitive to the motion of the sonar. At longer ranges the sonar should
be relatively motionless.

• Ethernet Test - 100Mbps

You can test your 100-Mbps link to make sure that the link throughput is available.
The test uses 95 percent utilization.

• Ethernet Test - 10Mbps

You can test your 10-Mbps link to make sure that the link throughput is available.
The test uses 95 percent utilization.

• Imaging

You can use this sonar application for navigation and obstacle avoidance. This
application uses a 30-degree Tx vertical beamwidth.

• Imaging Enhanced

Use this sonar application for imaging or obstacle avoidance using one of the
eIQ elements. This application uses a Time Delay FFT beamformer to produce a
high-quality image.

• Rub Test

Use this sonar application as part of a system test to make sure that the transducer
is receiving a signal. Rub the transducer and make sure that bright streaks or rings
appear in the sonar view.

• Customize Apps

Click to open the Customize Apps dialog box. You can select which sonar applications
will appear in the Sonar Apps menu.

Related topics
Choosing a sonar application, page 32
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Advanced menu
The Advanced menu is intended for experienced users or for testing purposes and is not
required for normal operation of the Flexview. This menu requires a software license
key, and will not appear if you do not have one.

How to open

To open this menu, click the menu title.
Description
• Power User Settings

Click to open the Power User Settings
dialog box. The Power User Settings dialog
box allows you to configure advanced
controls. You can also override the beamlist
or processing type during playback. The
Ping Rate, Update Rate, and Mode ID are
displayed for your information.

• Program Head

Click to open the Program Head dialog box. You can perform advanced tasks in the
Program Head dialog box, such as configuring production settings, making head
corrections, or changing transmit pulse definitions. This dialog box is only available
when the Sonar Head is connected and paused.

• Raw Data Frequency Spectrum

Click to open the Raw Data Spectrum window. The Raw Data Spectrum window
allows you to find and observe any noise in the data.

• Enable Network Sniffer

Click to open the Network Sniffer window. The Network Sniffer window allows you to
monitor network traffic in real-time. When this feature is enabled, the menu option
will change to Disable Network Sniffer.

Note

To use this feature, you must run the Flexview software as an administrator
(right-click on the icon and select Run as administrator).
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Help menu
The Help menu allows you to view hardware and software information in the About
Flexview dialog box. You can also open the Flexview Reference Manual from this menu.

How to open

To open this menu, click the menu title.
Description

About dialog box

The About dialog box identifies the current software version.
The version described in this publication is 1.3.1.

User Manual

Click User Manual to open the Flexview Reference Manual in PDF format. This manual
is only applicable to the software version you are using. If you are using an older version
of software, it will not be the latest version.

Tip

You can download the latest software from http://www.km.kongsberg.com/mesotechsoft-
ware, and the latest manuals from http://www.km.kongsberg.com/mesotechdocumenta-
tion.

Menu system

http://www.km.kongsberg.com/mesotechsoftware
http://www.km.kongsberg.com/mesotechsoftware
http://www.km.kongsberg.com/mesotechdocumentation
http://www.km.kongsberg.com/mesotechdocumentation
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Functions and dialog boxes

Topics
File menu, page 87

Display menu, page 79

Setup menu, page 81

Sonar Applications menu, page 82

Advanced menu, page 84

Help menu, page 85

Tool bar description, page 73
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File menu
The File menu allows you to open a recorded file, as well as choose the recording format
of your data files. You can also load your user settings from a previous software version.

How to open

To open this menu, click the menu title.
Description
• Playback

The Playback mode allows you to choose the echo data
file(s) you wish to play back.

• Stop Playback

Clicking Stop Playback will stop the playback of a
recording. You can also use the Playback Console to
control playback.

• Recording Format

Click Recording Format to choose between recording
raw sonar data (to a “.mmb” file) or recording beamformed sonar data (to a “.imb”
file).

• Load User Settings

Click to browse for a “UsersInfo.xml” file (in the folder
C:\KML\Flexview_V0131\bin\SettingsFlexview) from a previous software version.
You can import your previous settings to a new version of the Flexview software.

• Convert to Video

The Convert to Video Format dialog box allows you to convert an MMB or IMB
file to a video file (MP4 format only).

• Exit

Click to close the Flexview software.

Topics
Recording Format, page 88

Convert to Video Format dialog box, page 88
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Recording Format
Click Recording Format to choose between recording raw sonar data (to a “.mmb” file)
or recording beamformed sonar data (to a “.imb” file).

.mmb

.mmb is the default recommended recording format.

This is raw element data, not beamformed, in a 16-bit fixed-point complex format. This
format allows great flexibility in how the data is processed and allows you to do your
own beamforming or profile-point extraction. The data body size is determined by the
number of elements and the number of samples.

If you want to keep your recordings in .mmb format but process your data in .imb format,
you can convert .mmb files to .imb files using a batch conversion utility.

.imb

This format consists of beamformed data.

You can choose between a 32-bit floating point complex or 8-bit integer magnitude
format. Select the 8-bit format only if you are interested in imaging pixel data and want a
reduced data file size. The 8-bit format takes up a quarter of the 32-bit format's size.

Data body size is determined by the number of beams and samples. Different modes
may form a different number of beams. Therefore, data body size may change depending
upon the mode.

.imb files are easier to work with when using the Flexview MATLAB toolbox and can be
used with third-party software, such as Echoview.

Note

If files are recorded in .imb format, they cannot be converted to .mmb.

Related topics
Recording sonar data, page 47
Converting your recording format, page 49

Convert to Video Format dialog box
The Convert to Video Format dialog box allows you to convert an MMB or IMB file to
a video file (MP4 format only).

How to open

This dialog box is opened from the File menu.
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Description

Use this dialog box if you want to export a recording to a format that is playable by
any media player. This function is useful if you wish to share recordings with others
who do not have the Flexview software installed on their computers, or if you wish to
upload your recording to an online service.
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Details

Frame Rate

• Match Ping Rate

Select if you want the converted video frame time to match the ping time.

• One Frame per Ping

Select if you want each video frame to be converted from each sonar ping.

Gain Control

• Auto

Select to automatically adjust the gain during the video conversion.

• Manual

Select to apply a fixed gain setting to the entire video. Use this setting when
auto gain produces a video that is either too dark or too bright for a particular
data set. Click and drag the slider to choose the gain setting.

Resolution

You can select the desired resolution for the converted video. Note that higher
resolutions require longer conversion times and result in larger file sizes.

Note

Due to space limitations, text overlays will not be included when converting to a
resolution of 640x480p (the Display Overlay Text checkbox will not appear). Select
a higher resolution if you wish to include text overlays.

Quality

Select your video quality. A higher quality produces a video with a higher bit rate
and less compression. The result is a better-looking video, but a larger file size. If
storage space is a concern, choosing a lower quality will produce smaller files.

Palette

Select your preferred echo colours for the converted video file. Which colour scale
to use is mainly a personal preference based on ambient light conditions, the nature
of the echoes and your own experience.

Display Grid

You can choose whether to show the grid (range rings) in the video. You can also
select the desired grid shape.

Flexview Reference Manual



922-20207001/1.3 91

Date/Time

You can choose whether to display Coordinated Universal Time (UTC) Time or
Local Time in the Information Widget in the sonar view.

Note

During the winter, Local Time equals standard time. During the summer, Local
Time equals Daylight Saving Time (DST). Note that the offset between Local Time
and UTC Time is not constant, but varies in locations where DST is used.

Display Position

You can choose whether the video will display your position coordinates in the
Information Widget in the sonar view. You can also choose whether to display
latitude and longitude coordinates (geographic system) or a Northing/Easting
projection (projected coordinate system).

Display Filter

You can choose whether to apply a filter to the sonar view video. You can select
which type of filter to apply. Drag the slider to increase or decrease the strength of
the filter.

Display Mirror

Select this checkbox to mirror the sonar image in the converted video file (port to
starboard, starboard to port).

Display Sensor Data

Select this checkbox to show sensor data in the Information Widget in the sonar
view.

Display Overlay Text

Select this checkbox to show text overlays. To create text overlays for your video,
click Setup→Preferences and fill out the Overlay Text boxes.

Sidelobe Suppression

Select this checkbox to enable the Sidelobe Reduction function for your video. This
function improves overall image quality by reducing the sidelobes of strong targets.
Sidelobe reduction is especially useful at short ranges when targets are very close.
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Folder Conversion

Select this checkbox to perform a batch conversion of all sonar recordings in a
selected folder. If you select this option, you will not be able to change the name
of the converted files. Auto Name will be selected under the Target file naming
convention drop-down list and the other options will not be available.

Note

The Source File button will change to Source Folder. An additional progress bar
will appear at the bottom of the dialog box to show you how many files are being
converted.

Source File/Source Folder

Click this button to select a recording or a folder for conversion (only .mmb or
.imb files are supported).

Max File Size

Long data recordings will produce very large file sizes. Select the maximum file
size for your video files.

If the maximum file size is reached, but the data conversion is not finished yet, a
new file will be created. Each filename created for the converted recording will
be given a unique filename with a sequential number.

Target Folder

Click this button to open a browser window where you can select a location for the
converted video file(s).

Target file naming convention

Select a name for the converted file. Selecting Auto name will preserve the original
filename and save the converted file in the same location as the original. Selecting
User defined will allow you to enter your own filename into the Target File box.
There are also some predefined filenames available.

Target File

Click this button to select a filename and location for the converted video file.
This button is only available if you select User defined for the Target file naming
convention.

Convert

Click this button to start the conversion.

Note

The range annotations (metres or feet) displayed in the converted video file will be the
same as currently configured in the Flexview software. You can change the units of
measurement in the Preferences dialog box.
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Related topics
Playing back a recording, page 48
Converting your recordings to video, page 51
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Display menu
Use the Display menu to control the visual aspects of the system, and to show or hide
various elements in the presentation.

How to open

To open this menu, click the menu title.
Description
• Enable Target Marker

Click to enable the Target Marker function.
You can press 0–9 to place a marker in the sonar
view that is stamped with time and location
information. In addition, you can export this
information to a serial or UDP port.

• Delete All Markers

Click to remove all target markers from the sonar
view.

• Full Screen

Click Full Screen to make the sonar view full
screen. Press the Esc key to exit full-screen mode.

• Output Messages window

Click to show or hide the Output Messages
window. The Output Messages window displays
information, diagnostic, and error messages.

• Playback Console

Click to show or hide the Playback Console.
Control playback using the Playback Console. You
can stop, pause, fast forward, or advance through
the recording one ping at a time. You can also
repeat playback of the file on a never-ending loop.

• Rotator Control

Click to show or hide the Rotator Control dialog box for each rotator you have
installed.

• Tool bar

Click to show or hide the tool bar. The tool bar provides buttons for functions, filters,
and sonar view overlays.

• Annotations
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Click Annotations to enable or disable the bearing and range annotations in the sonar
view.

• Font Size

You can choose between using a normal or a large font size throughout the Flexview
software.

• Palette

Select Palette to choose your preferred echo colours. Which colour scale to use is
mainly a personal preference based on ambient light conditions, the nature of the
echoes and your own experience.

• Sector Orientation

Enter an angle (in degrees) into the Orientation dialog box, then click Apply to rotate
the sonar view to your chosen angle.

• Heading Overlay

If your Sonar Head is forward looking, click Heading Overlay to enable or disable this
feature. When this feature is enabled, the degree annotations in the sonar view will
change to reflect the current sonar heading.

• Speckle Filter

Click Speckle Filter to enable or disable this function. This filter reduces noise (the
grainy “salt-and-pepper” pattern) in uniform areas of the sonar view. Distinguishable
details in features and targets will be retained.

• Sidelobe Reduction

Click Sidelobe Reduction to enable or disable automatic sidelobe reduction. This
function improves overall image quality by reducing the sidelobes of strong targets.
Sidelobe reduction is especially useful at short ranges when targets are very close. In
addition, the automatic adjustments work well when the sonar is constantly moving,
such as on an ROV.

Tip

If you have a software license for advanced features, you can view the
automatically-calculated sidelobe reduction ratio or manually adjust the ratio using
a slider.

• Reset to Default Layout

Click to reset the presentation layout. All windows and dialog boxes will be docked
in their default location. In addition, some display elements are hidden by default.

Topics
Target Marker Export dialog box, page 96

Playback Console, page 98
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Target Marker Export dialog box
The Target Marker function is primarily used for remotely operated vehicle (ROV)
navigation. Third-party ROV software can use the time and location information to
steer the ROV toward the target.

How to open

This dialog box is opened from the Display menu.
Description

You can place a marker on a target
of interest in the sonar view. This
marker is stamped with both time and
location details. You can export this
time and location information to a
serial port (or UDP port 20004).

To start using target markers, click
Display→Enable Target Marker.

The Target Marker Export dialog box
opens when you enable the Target Marker function.

Choose a serial port in the Target Marker Export dialog box, then click OK to enable
serial port export. Click Cancel to use the Target Marker function without exporting to a
serial port. UDP export is available in both cases.

Once the Target Marker function is enabled, pressing number keys 0 to 9 will place a
marker at the location of the arrow cursor in the sonar view.

Details

Port

Select which serial port you want to export the time and location information to.

Serial port parameters

The serial port parameters are fixed and cannot be changed. Ensure that your
third-party software is set to receive the data using these values.

• Baud Rate

9600

The speed of the serial communication.

• Data Bits

8

The number of data bits in each character.
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• Parity

N

If required, a parity bit is used in a simple error detection algorithm for a serial
port.

• Stop Bits

1

This parameter is used to indicate the end of the transmission. It is usually
set to 1.

Target Marker format

$MSTRK,xx,hhmmss.ss,nnnnnnnn.nn,c,eeeeeeee.ee,c,U<CR><LF>
$MSTRK Start character and prefix.
xx Target number, ranging from 00 to 99.
hhmmss.ss UTC time in hours, minutes, and seconds.
nnnnnnnn.nn Northing or Latitude depends on the “U” definition.
c N: North; S: South
eeeeeeee.ee Easting or Longitude depends on the “U” definition.
c E: East; W: West
U ‘f’: Northing/Easting in feet. Variable number of digits

for Northing/Easting and variable number of digits for
decimal-fraction of Northing/Easting.

‘m’: Northing/Easting in metres. Variable number of
digits for Northing/Easting and variable number of digits
for decimal-fraction of Northing/Easting.

‘l’: Lat/Lon in degrees. For Latitude: two fixed digits
of Latitude degrees, two fixed digits of minutes, and a
variable number of digits for decimal-fraction of minutes.
For Longitude: three fixed digits of Longitude degrees,
two fixed digits of minutes, and a variable number of
digits for decimal-fraction of minutes.

CRLF Termination

Related topics
Placing target markers, page 61
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Playback Console
You can play back a previously recorded data file to view the sonar image sequence
captured during operation of the Sonar Head. Control playback using the Playback
Console.

How to open

The Playback Console is opened from the Display menu. The Playback Console is also
opened automatically when you choose a file for playback.

Description

A The name of the playback file in use and the time and date of the recording.
B The playback progress bar. Click and hold, then drag your mouse along the bar to

search through the recording. Click anywhere in the bar to jump to a specific point.
C Click to stop the recording.
D Click to pause the recording.
E Click to fast forward through the recording.
F Click to advance through the recording one ping at a time.
G Click to repeat playback of the file on a never-ending loop.
H Click to close the Playback Console. Closing the Console will not stop playback.

Related topics
Playing back a recording, page 48
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Setup menu
You can connect to the Sonar Head using the Setup menu. You can also configure the
system, choose your preferences, set up the coordinate system, upgrade the Sonar Head
firmware, or change the Sonar Head IP Address.

How to open

To open this menu, click the menu title.
Description
• Connect

Click Connect to connect to the Sonar Head
and start “pinging”.

Note

When the Sonar Head is running, this menu
command will change to Disconnect.

• Define Custom Sensor

Click to open the Define Custom Sensor dialog box. If the sensor protocol you want to
use is not available on the Sensors Setup page, you can create a custom sensor format
in the Define Custom Sensor dialog box.

• Geo Projection

Click to open the Geo Projection dialog box. You can configure the coordinate system
using the Geo Projection dialog box.

• Preferences

Click to open the Preferences dialog box. The Preferences dialog box is used to set up
system preferences such as units of measure, time format, etc.

• Head Network Setup

Click to open the Head Network Setup dialog box. The Head Network Setup dialog
box allows you to change the Sonar Head network parameters, such as the IP address.
This dialog box is only available when the Sonar Head is connected and paused.

• Head Firmware Configuration

Click to open the Head Firmware Configuration dialog box. The Head Firmware
Configuration dialog box allows you to upgrade the Sonar Head firmware. This dialog
box is only available when the Sonar Head is connected and paused.

• System Configuration

Click to open the System Configuration dialog box. This dialog box allows you to
set up the Sonar Head, external sensors (such as a GPS or Motion Reference Unit),
and rotators. In addition, you can configure the deployment of the Flexview and
enter mounting offsets.
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Topics
Define Custom Sensor dialog box, page 100

Geo Projection dialog box, page 103

Preferences dialog box, page 105

Head Network Setup dialog box, page 109

Head Firmware Configuration dialog box, page 111

System Configuration dialog box - Sonar Setup page, page 113

System Configuration dialog box - Sensors Setup page, page 116

System Configuration dialog box - Rotators Setup page, page 119

System Configuration dialog box - Master Reference page, page 126

System Configuration dialog box - Mounting Offsets page, page 129

Define Custom Sensor dialog box
If the sensor protocol you want to use is not available on the Sensors Setup page, you can
create a custom sensor format in the Define Custom Sensor dialog box.

How to open

This dialog box is opened from the Setup menu.
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Description

Many third-party sensors or ROV systems export sensor strings through a UDP or serial
connection. These sensor strings include various data types such as position, heading,
depth, pressure, altitude, pitch, roll, and water temperature. The third-party sensor string
may not conform to the universal NMEA standard and will change depending on the
sensor or ROV manufacturer.

You will find many supported sensor formats in the Protocol drop-down list found on
the Sensors Setup page in the System Configuration dialog box. However, if a particular
third-party sensor format is not listed there, you can create it (using the third-party
sensor specification as your guide).

Note

After you are done creating the custom sensor format, it will appear in the Protocol
drop-down list on the Sensors Setup page.

The sensor string is comprised of a sentence with defined parts: Message ID + Sensor
Format and Delimiters + Termination.
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Details

Message ID

The start (prefix) of the sensor sentence. Refer to the manufacturer's sensor
specification to determine what to use. For example, “:” or “$GPRMC”.

Delimiter(s)

The character used to separate each string in the sentence. You can select more
than one if necessary - each character will be treated as one delimiter. Refer to the
manufacturer's sensor specification to determine what to use.

Termination

The ASCII character that tells the software where the sensor string ends. Options
include a carriage return (CR), line feed (LF), or both. Refer to the manufacturer's
sensor specification to determine what to use.

Sensor Format

Define the entire sensor string in this field.

Enter the Message ID, followed by the chosen delimiter. Enter in one or more of
the three-letter definition strings from the list on the right side of the dialog box.
Match each three-letter string with the data type in the sensor specification. For
example, enter "ALT" for the part of the sensor sentence corresponding to Altitude,
and so on. Separate each string with the chosen delimiters. If you can't find any
part of the sensor sentence on the right-side list, then enter the "Ignored field"
string (III). This will tell the software to skip over this part of the sensor sentence
when parsing the string.

For example: “: ALT DEP HDG ROL PIT” defines a sensor sentence with the
Message ID “:” and five fields for Altitude, Depth, Heading, Roll, and Pitch
separated by space delimiters.

Data Type

If the data type in the sensor sentence is an integer (for example, 1002), then
select Whole number. If the data type in the sensor sentence is a float (for
example, 10.02), then select Decimal number. Refer to the manufacturer's sensor
specification to determine what to use.

Latitude / Longitude Format

Choose whether to display the latitude/longitude format in degrees, degrees and
minutes, or degrees, minutes, and seconds.

Unit Scale Factor

The dialog box will tell you what unit scale the software expects (meters, degrees,
meters per second, and so on). If the data type in the specification does not
match the required unit scale, you must enter an appropriate scaling factor. For
example, if the Depth data type is in feet, then you must enter 0.3048 to scale the
depth value to meters.
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Sensor Name

This name will appear in the Protocol drop-down list found on the Sensors Setup
page in the System Configuration dialog box.

Related topics
Defining a custom sensor, page 40

Geo Projection dialog box
You can configure the coordinate system using the Geo Projection dialog box.

How to open

This dialog box is opened from the Setup menu.
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Description

This dialog box allows you to convert the latitude and longitude data from your GPS into
a coordinate system of your choice. For example, you may wish to match the coordinate
system used in your survey maps. You can display location data as Easting and Northing
coordinates measured from a horizontal datum. You can also set the zone so that accurate
location data is embedded in any GeoTiff files that you create.
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Details

Datum

• Latitude / Longitude

Select a datum for latitude and longitude coordinates (geographic system).

• Northing / Easting

Select a datum for a Northing/Easting projection (projected coordinate system).

• Zone

Select a zone for a Northing/Easting projection.

• Display Coords In

Choose which coordinate format you want to use in the sonar view when
displaying location information.

• Latitude / Longitude Format

Choose whether to display the latitude/longitude format in degrees, degrees and
minutes, or degrees, minutes, and seconds.

• Datum Parameters

The Datum Parameters button will become available when selecting the
BEIJING_1954 datum. Clicking the Datum Parameters button will open a
dialog box with a number of fields specific to this datum.

Calculator

You can use the calculator as a tool to convert your location from one coordinate
system to another.

Preferences dialog box
The Preferences dialog box is used to set up system preferences such as units of measure,
time format, etc. This dialog box also allows you to select the save location for
screenshot images and recorded sonar data files.

How to open

This dialog box is opened from the Setup menu.
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Description

The Preferences dialog box allows you to customize the software. In addition, you can
configure features such as GeoTiff Auto Save and UDP Data Export. You can also
configure unique filenames and save locations.
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Details

Units

• Meters

Select to display all units of measurement in meters.

• Feet

Select to display all units of measurement in feet.

Cursor Options

• Range / Bearing

Select to show the range and bearing of the current mouse position at the bottom
of the sonar view.

• X / Y

Select to show the X and Y coordinates of the current mouse position at the
bottom of the sonar view.

• Geographic

Check this box if you want to display the coordinates of the mouse position at
the bottom of the sonar view.

Tip

You can configure the coordinate system using the Geo Projection dialog box.

Time System

• Local Time

Select to use the current time at your location.

• UTC Time

Select to use Coordinated Universal Time (UTC).

Note

During the winter, Local Time equals standard time. During the summer, Local
Time equals Daylight Saving Time (DST). Note that the offset between Local
Time and UTC Time is not constant, but varies in locations where DST is used.

Overlay Text

Fill out the Overlay Text boxes if you wish to display information on your
screenshots and data recordings.
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File Saving

• Prompt User for Filename

Check this box to open a “Save As” dialog box when you record data or save
an image.

• Export Sensor Data

Check this box to save timestamped sensor data to a text file (in CSV format).
When this feature is enabled, a text file will be created every time the sonar runs
or a recording is played back. The text file is saved in the Recordings folder
shown in this dialog box. If you export a recording to video, then the text file
will be saved in the Target Folder shown in the Convert to Video Format dialog
box.

Tip

If you need to troubleshoot sensor data logging issues, you can compare the
sensor data text file to the NAV file provided by a survey or ROV on-board
the vessel.

• Name

Type any name into the text box. The chosen name will be used as prefix in
all the data file names. The time/date stamp will be used as the filename if
the name field is left blank.

• Use C:\KML\Flexview_V0131

Check this box to use the default location when saving files. Disable this setting
if you want to choose alternative save locations. The Browse buttons will
become available.

GeoTiff Auto Save

• Distance / Time

To automatically save a GeoTiff file every set number of meters, select Distance
and enter a value. To automatically save a GeoTiff file every set number of
seconds, select Time and enter a value.

Tip

Press F11 to enable or disable GeoTiff auto save. The status bar will display
“GeoTiff” in green when auto save is enabled.

• Cropped Width

To save a cropped GeoTiff image for mosaicking purposes, enter the percentage
to crop.
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Related topics
Configuring your preferences, page 30

Head Network Setup dialog box
The Head Network Setup dialog box allows you to change the Sonar Head network
parameters, such as the IP address.

How to open

This dialog box is opened from the Setup menu.

Note

This dialog box is only available when the Sonar Head is connected and paused. To
pause the Sonar Head, click Setup→Connect, then open the Menu Widget in the top-right
corner of the sonar view. Click Pause.

Description

You can program the IP address and the IP port of the Sonar Head for various network
environments. The factory default IP address is 192.168.1.234, and the default port
number is 30.

To change the Sonar Head IP address, click Read from Head to get the information from
the Sonar Head. Edit the fields, then click Write to Head.
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Details

Head Name

The name assigned to the Sonar Head. You cannot change this parameter — it
is read only.

Serial Number

The unique serial number of the Sonar Head. You cannot change this parameter
— it is read only.

Automatic IP address allocation

Determines whether the Sonar Head can be assigned an IP address from a DHCP
Server. By default, the Sonar Head uses a static IP address. You cannot change this
parameter — it is read only.

VDSL Profile

The VDSL2 standard defines various profiles that can optimize the data rate and
link performance on cables of different quality and lengths. For longer cables, you
may wish to use a profile with a lower bandwidth, such as profile 0 (8b) or 1 (12a).

The following profiles are available:

• 0 (8b): Suitable for long or low-quality cables, but has a slower data rate.

• 1 (12a): A good compromise for medium-length cables, or cables that are of
marginal quality, and provides a medium-speed data rate.

• 2 (30a): Suitable for short cables. Provides a fast data rate.

• 3 (30a): Provides the fastest data rate but is only suitable for very short cables.

Note

The maximum achievable data rate depends on a number of factors, such as cable
length, the number of junctions, and your slip ring installation. You can measure
the link speed by performing the “Testing the Sonar Head telemetry” procedure.

VDSL SNR Margin

The VDSL Signal to Noise Ratio (SNR) Margin controls the amount of noise and
tolerance in the cable. It is the difference between the actual SNR and the minimal
SNR required to sync at a specific speed. For longer cables, use 6 dB instead
of 9 dB.
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IP Address, Port, Subnet Mask, and Default Gateway

These network parameters are used to identify and locate the Sonar Head on the
local network. If you need to set up a unique network environment, you can change
the IP Address, Port, Subnet Mask, and Default Gateway of the Sonar Head using
the Head Network Setup dialog box.

Note

Your Sonar Processor must be on the same network as the Sonar Head.

Get Default

Click this button to populate the fields with the default network settings for the
Sonar Head.

Write to Head

Click this button to re-program the Sonar Head with the parameters that you have
entered.

Read from Head

Click this button to populate the fields with the current parameter values.

Related topics
Changing the Sonar Head IP Address, page 65
Testing the Sonar Head telemetry, page 24

Head Firmware Configuration dialog box
The Head Firmware Configuration dialog box allows you to upgrade the Sonar Head
firmware.

How to open

This dialog box is opened from the Setup menu.

Note

This dialog box is only available when the Sonar Head is connected and paused. To
pause the Sonar Head, click Setup→Connect, then open the Menu Widget in the top-right
corner of the sonar view. Click Pause.
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Description

In addition to head application software, the Sonar Head has receive firmware (RX
FPGA) and transmit firmware (TX FPGA). You can upgrade these by selecting the
configuration type, browsing for the file, then clicking theWrite button.

Note

The receive hardware (RX HW) and software (RX SW) must both be on the same version.
You can view the current version numbers in this dialog box.

Details

Head

The Head table shows you the serial number and IP Address of the Sonar Head.

Configuration type

Select the type of software or firmware that you are upgrading.

Configuration file

Click the folder icon to browse for the latest software or firmware file on your
local drive.
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Read

Enter a filename in the Configuration file box, then click Read to save the firmware
or software to a file. You can create a backup of your current software or firmware
with this feature.

Write

Click this button to start the upgrade process. You will be prompted to confirm
the upgrade.

Related topics
Upgrading the Sonar Head, page 63

System Configuration dialog box - Sonar Setup page
You can discover and connect to the Sonar Head on the Sonar Setup page. You can also
view the Sonar Head network properties and adjust the network link speed.

How to open

This dialog box is opened from the Setup menu.

Select the Devices→Sonar Setup tab.

Note

This page is not available while the Sonar Head is running.
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Description

This dialog box allows you to connect to the Sonar Head. You can connect manually or
automatically each time you start the software. This dialog box also provides diagnostic
network tools.
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Details

Device Properties

Tip

You do not have to enter in the Device Properties manually. Clicking Discover
Sonar Heads, then Use Discovered Head will automatically populate the Device
Properties fields.

• Head Name

You can enter any name to identify the Sonar Head.

• Serial Number

The unique serial number of the Sonar Head.

• IP Address, Port, Subnet Mask, and Default Gateway

These network parameters are used to identify and locate the Sonar Head on
the local network. Your Sonar Processor must be on the same network as the
Sonar Head.

Tip

If you need to set up a unique network environment, you can change the IP
Address, Port, Subnet Mask, and Default Gateway of the Sonar Head using
the Head Network Setup dialog box.

• Trigger Mode

If applicable, set the Trigger mode to synchronize the Sonar Head with another
acoustic device (such as a second Flexview Sonar Head or a sub-bottom
profiler). Set the trigger mode to Master to send out a sync pulse so that the
other acoustic device can be triggered. Set the trigger mode to Slave to be
triggered by the sync pulse from the other device. For the Flexview, the default
is set to Master.

• Time Sync Mode

Your computer can keep accurate time by using a GPS or network time server
as the master time source. When connecting to the Sonar Head, it takes two
minutes to synchronize the time to within five milliseconds. The Flexview
software will then continuously keep the Sonar Head clock in sync for the
duration of the session. The status bar shows the time synchronization status.

Get Default

Click this button to use the default network settings to connect to a Sonar Head.

Autoconnect at program start

Check this box to connect to the Sonar Head automatically the next time the
software starts.
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Override Network Link Speed

If telemetry quality is poor, you can limit the network link speed. Be default,
the network link speed is limited to 100 Mbps. There are no standard sonar
applications with a telemetry-link speed requirement higher than 100 Mbps.

Note

Overriding the network link speed will provide a more stable link connection,
but a slower ping rate.

Network log level

This setting outputs network-related diagnostic messages to the Output Messages
window and a “.log” file (found in the LOGS directory) for troubleshooting
purposes. You can select the amount of detail provided, ranging from none (No
logging) to high (Detailed info). When logging is enabled, ping loss, packet loss
and the last ping data rate will be displayed on the status bar.

Discover Sonar Heads

Click Discover Sonar Heads to search for the sonar on the network.

Use Discovered Head

Click Use Discovered Head to connect to the discovered head.

Related topics
Starting operation of the Sonar Head, page 29
Testing operation of the Sonar Head, page 22

System Configuration dialog box - Sensors Setup page
The Sensors Setup page allows you to configure external sensors (such as a GPS to
provide navigation information).

How to open

This dialog box is opened from the Setup menu.

Select the Devices→Sensors Setup tab.

Note

This page is not available while the Sonar Head is running.
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Description

If you have external sensors that provide speed, heading, or latitude/longitude
coordinates, then this dialog box allows you to set them up. Readings from these sensors
will appear in the Information Widget located in the sonar view.
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Details

Add Device

Click this button to add a sensor for data import.

Remove Device

Click this button to remove the selected sensor from the Sensor Devices list.

Test Device

Click this button to start a sensor test. The sensor data will be displayed in the
Port Monitor box.

Device Properties

• Name

Enter any name into this field to label the device.

• Protocol

This drop-down lists all supported datagram formats.

• Port Location

The location of the port receiving external sensor data – can be a COM port,
a UDP Ethernet port, or a port on the Sonar Head.

• Port#

This drop-down lists the available port numbers. Select the port where the
device is connected.

• Baud Rate

Specify the baud rate (“speed”) for the serial communication. The standard
baud rate defined for NMEA communication is 4800.

• Data Bits

Select the number of data bits for the serial communication.

Note

The standard number of data bits defined for NMEA serial line communication
is 8 (eight).

• Parity

Specify the parity for the serial communication.

Note

If required, a parity bit is used in a simple error detection algorithm for a serial
port. Standard parity defined for NMEA serial line communication is "None".

Flexview Reference Manual



922-20207001/1.3 119

• Stop Bits

This parameter is used to indicate the end of the transmission. It is usually
set to 1.

• Interface

This drop-down lists possible serial communication methods.

Related topics
System Configuration dialog box - Master Reference page, page 126

System Configuration dialog box - Rotators Setup page
Rotators are required if you wish to pan or tilt the Flexview during operation. Use the
Rotators Setup page to set up and test your rotators.

How to open

This dialog box is opened from the Setup menu.

Select the Devices→Rotators Setup tab.

Note

This page is not available while the Sonar Head is running.
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Description

The Flexview software supports the following rotators.
• Kongsberg OE 10-102: Dual-Axes Pan and Tilt unit
• Kongsberg OE10-103: Single-Axis Pan unit
• Kongsberg Mesotech 806-00360000 (SS350): Single-Axis high-precision Pan unit

You must connect your rotator to a PC COM port.

Details

Add Device

Click this button to add a rotator.
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Remove Device

Click this button to remove the selected rotator from the Rotators list.

Test Device

Click this button to open the Rotator Test dialog box.

Device Properties

• Name

Enter any name into this field to label the device.

• Unit

Select the rotator model you have from the list.

• Device Axis

Select one sonar axis if you are using a single-axis unit, or select two sonar
axes for a dual-axes unit.

There are three possible sonar axes. To view the orientation of each axis, click
System Configuration→Deployment→Mounting Offsets and select each axis in
the Rotators section. Observe the animation to see the rotation of each axis.

• Port Location

Select which port the rotator is connected to — can either be a COM port or
a Sonar port.

• Port#

This drop-down lists the available port numbers. Select the port where the
device is connected.

• Baud Rate

Specify the baud rate (“speed”) for the serial communication.

• Data Bits

Select the number of data bits for the serial communication.

• Parity

Specify the parity for the serial communication.

Note

If required, a parity bit is used in a simple error detection algorithm for a serial
port.

• Stop Bits

This parameter is used to indicate the end of the transmission. It is usually
set to 1.
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• DeviceCommID

The rotator manufacturer assigns this network identifier for communication
between the rotator and the software. The default for newer rotator models
is “3”. The default for older rotator models is “2”. If you are experiencing
communication problems with your rotator, make sure that you have selected
the correct ID for your model.

Related topics
System Configuration dialog box - Mounting Offsets page, page 129
Controlling the rotator, page 43

Rotator Test dialog box

Test your rotators in this dialog box by making sure you can connect to the rotator and
send commands to it.

How to open

This dialog box is opened from the Rotators Setup page in the System Configuration
dialog box.

Click the Test Device button to open this dialog box.

Description

Use this dialog box to test the rotator rotation speed, rotator movement, and pan and tilt
operation (for dual-axes rotators).
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If you have selected a single-axis rotator, then the following dialog box is used.

Note

This dialog box shows the options for the Kongsberg OE10-103. The Kongsberg
Mesotech 806-00360000 (SS350) is similar, except a Calibrate button appears. You must
click this button to correctly align the rotator after powering down and powering up (this
rotator does not keep absolute zero indexing). In addition, there is no option to set up
soft stops (this rotator has fixed hard and soft stops).

Functions and dialog boxes



124 922-20207001/1.3

If you have selected a dual-axes rotator, then the following dialog box is used.

Details

Connect

Click this button to connect to the rotator.

Disconnect

Click this button to disconnect from the rotator.

Current Position

Shows the current rotator position in degrees.

A Calibrate button will appear here is you are using the Kongsberg Mesotech
806-00360000 (SS350) rotator. Click this button to reset the zero index after
powering down then powering up.
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Directional Move

For single-axis rotators, use the Speed control to set the rotator rotation speed.
Click and hold the Go Up button to move the rotator up. Click and hold the Go
Down button to move the rotator down. Check the Reverse Rotator Direction box if
your rotator has been installed in a reversed position.

If you have a dual-axes rotator, you will be presented with arrow icons. Click
the up and down arrow icons to tilt up or down. Click the left and right arrows
to pan left or right. Check the Switch Axes box to invert the controls so that the
up/down arrows are used to pan and the left/right arrows are used to tilt. You
can adjust the tilt and pan speeds by dragging the sliders. Check the Reversed
Tilt Rotator Direction box if your rotator is installed with the tilt axis reversed.
Check the Reversed Pan Rotator Direction box if your rotator is installed with
the pan axis reversed.

Soft Stops

Check the Use Soft Stops box to use a software function to set the rotator stops,
so that the rotator will not rotate beyond the stops during operation. To avoid
hitting objects or twisting cables when rotating, hard stops (pins) are usually bolted
onto the rotator mount to stop rotation at predefined positions. However, soft
stops allow you to program the rotator stops in the Flexview software to mitigate
mechanical wear and avoid shearing the hard stops.

To set the soft stops, uncheck the Use Soft Stops box. Set up the soft stops by
moving the rotator until it reaches the limit where the attached devices or cables
still have clearance.

• Click the Go Up button/up arrow to move the rotator up to the desired position,
then click the Set Up Stop button.

• Click the Go Down button/down arrow to move the rotator down to the desired
position, then click the Set Down Stop button.

• Click the right arrow (dual-axes only) to move the rotator right to the desired
position, then click the Set Right Stop button.

• Click the left arrow (dual-axes only) to move the rotator left to the desired
position, then click the Set Left Stop button.

Re-check the Use Soft Stops box when you are done.
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Positioning

You can use the positioning function to move the rotator to a specific position (in
degrees). Use this function for precise and quick positioning instead of clicking
the Go Up or Go Down buttons. Enter a degree in the To position field, then click
Goto (single-axis only). You can also rotate in degree increments by entering a
degree into the Step by size field, then clicking Step Up or Step Down to rotate to
the next/previous increment.

If you have a dual-axes rotator, you can enter a degree into the Tilt to position or
Pan to position fields, then click the associated button to move the Sonar Head
to that position on the tilt or pan axis.

Click the Stop Move button to cancel the rotation.

Rotator Control Dialog Type

Set the Rotator Control Dialog Type before you start operation of the sonar.

Select Pan/Tilt Control if you wish to manually move the Sonar Head up, down, or
sideways during operation. The 3D Scan option is not supported on the Flexview.

System Configuration dialog box - Master Reference page
On the Master Reference page, you can assign any external sensors you have set up as
the primary source for various types of navigational data.

How to open

This dialog box is opened from the Setup menu.

Select the Deployment→Master Reference tab.

Flexview Reference Manual



922-20207001/1.3 127

Description

When using the Flexview for imaging, set up sensors for Position and Heading if you
want to create GeoTiff files or create a real-time mosaic.

If no sensor input is required for a particular reference, you may leave the value set to
Fixed. When setting a value to Fixed, you can enter the fixed value into the adjacent
text box.

Details

Configuration

Select the desired configuration from the drop-down list. Click New to create a
new configuration based on the default settings. Click Save As to save the current
configuration or Delete to delete the current configuration.

Master Reference

• Position

A location derived from measuring external reference points.
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• Depth

The vertical distance downwards from the water surface.

• Heading

The direction in which a vessel is pointing, as opposed to the course made good.

• Magnetic Variation

If you are using a magnetic heading sensor, enter the local magnetic variation
into the Magnetic Variation box to get true heading. This parameter can be
changed while the Sonar Head is running.

• Pitch/Roll

Pitch is the up/down rotation of a vessel about its lateral axis. Roll is the tilting
rotation of a vessel about its longitudinal axis.

• Heave

Heave is the linear vertical (up/down) motion of the vessel.

• Sound Speed

This shows the current sound speed value, whether it is provided by a sensor,
calculated or entered manually. A sound speed sensor is required to accurately
measure in-water speed near the Sonar Head. This parameter can be changed
while the Sonar Head is running.

Check the Override Sound Speed box if you want to replace the sound speed
value in your recording with a fixed value during playback. This may be
necessary, for example, if your recorded sound speed is not accurate.

Note

You can override the sound speed in .mmb files only.

• Altitude

Altitude is the vertical distance from the sensor to the seafloor. If you need the
depth below the transducer, use the NMEA DBT datagram.

Related topics
System Configuration dialog box - Sensors Setup page, page 116
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System Configuration dialog box - Mounting Offsets page
The mounting offsets are required to calibrate the position of the Sonar Head relative to
the GPS antenna. If you have a rotator, you must calibrate the position of the rotator
relative to the Sonar Head.

How to open

This dialog box is opened from the Setup menu.

Select the Deployment→Mounting Offsets tab.

Note

This page is not available while the Sonar Head is running.
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Description

When you mount your Flexview Sonar Head on an ROV, you will need to specify where
the Sonar Head is positioned in three-dimensional space relative to the GPS antenna.

Inaccurate mounting offsets will display your sonar data incorrectly in the sonar view.

Tip

If you have recorded your sonar data using the wrong offsets, you can still fix the offsets
using this dialog box. Check the Override Mounting Parameters box to apply the correct
mounting offsets to your recording.
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Details

Mounting

• X Offset

X is defined as the Sonar Head relative to the GPS antenna across track. Port
is negative and Starboard is positive.

• Y Offset

Y is defined as the Sonar Head relative to the GPS antenna along track. Aft is
negative and Fore is positive.

• Z Offset

Z is defined as the Sonar Head relative to the GPS antenna’s vertical distance.
Down is negative and Up is positive.

• Orientation

This drop-down list allows you to select a number of pre-configured Sonar Head
orientations. Observe the animation to make sure your Sonar Head is facing in
the correct direction for the selected orientation. The orientation depends on
how you are using the Flexview. For example, a forward-facing orientation can
be used for obstacle avoidance on a remotely operated vehicle (ROV). If you
wish to create your own orientation, select Custom, then enter in the precise
pitch, roll, and yaw angles of the Sonar Head position.

Tip

If images appear on the wrong side of the sonar view (for example, objects on
the right appear on the left), then select one of the “Inverted” orientations.

Rotators

Select the rotator you wish to configure from the Rotators list. You can see which
axis has been assigned to each rotator.

• Radius

The radius offset is necessary if your Sonar Head is attached to the rotator with
an arm. The length of the arm can be entered as the radius.

• Angle

Entering an angle is not necessary if the transducer face of the Sonar Head is
aligned with the rotator. However, if the Sonar Head is installed at an angle to
the rotator, then enter that value here.
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Override Mounting Parameters

Enabling this option will apply the current offsets on this page during playback
instead of the offsets recorded in your data file.

Tip

If you apply the offset override, playback a file, then re-record a new file during
playback, the offsets will not be applied to the new re-recorded file (the new file will
use the original offsets). However, if you export data to a third-party application in
playback mode, the offset override will be applied to the exported data.

Related topics
System Configuration dialog box - Rotators Setup page, page 119
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Sonar Applications menu
The Sonar Applications menu lists various operating modes used for different
applications. Each mode has its own pre-defined characteristics, such as differing ranges,
angular resolutions, and pulse types.

Note

You cannot select a sonar application until the Sonar Head is connected. All Sonar
Applications menu items will be greyed out until the sonar is running.

How to open

To open this menu, click the menu title.
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Description
• EIQ (500-kHz transducer only)

This sonar application captures high-quality images.
At short ranges the images are relatively insensitive
to the motion of the sonar. At longer ranges the
sonar should be relatively motionless.

Note

This application is less sensitive to motion than EIQ
- Fine.

• EIQ - Fine (500-kHz transducer only)

This sonar application captures very high-quality images. At short ranges the images
are relatively insensitive to the motion of the sonar. At longer ranges the sonar should
be relatively motionless.

• Ethernet Test - 100Mbps

You can test your 100-Mbps link to make sure that the link throughput is available.
The test uses 95 percent utilization.

• Ethernet Test - 10Mbps

You can test your 10-Mbps link to make sure that the link throughput is available.
The test uses 95 percent utilization.

• Imaging

You can use this sonar application for navigation and obstacle avoidance. This
application uses a 30-degree Tx vertical beamwidth.

• Imaging Enhanced

Use this sonar application for imaging or obstacle avoidance using one of the
eIQ elements. This application uses a Time Delay FFT beamformer to produce a
high-quality image.

• Rub Test

Use this sonar application as part of a system test to make sure that the transducer
is receiving a signal. Rub the transducer and make sure that bright streaks or rings
appear in the sonar view.

• Customize Apps

Click to open the Customize Apps dialog box. You can select which sonar applications
will appear in the Sonar Apps menu.

Topics
Enhanced Image Quality (EIQ), page 135

Imaging, page 135
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Enhanced Image Quality (EIQ)
Enhanced Image Quality (EIQ) applications are intended for slower moving operations
where the vehicle or vessel is moving slowly, or is stationary for at least a few seconds.

Description

The Fine EIQ applications overlap beams to improve image quality. EIQ uses four
pings. EIQ - Fine uses eight pings. Note that the Fine EIQ applications have a slower
sonar view refresh rate.

We recommend a maximum vessel speed of two knots for EIQ mode and 0.5 knots for
EIQ - Fine mode.

Details
Sonar Application Names: EIQ

EIQ - Fine
Range: 0.4 m to 150 m
Angular Resolution: 0.95° x 30°
Pulse Type: Continuous Wave and Linear FM (Chirp)

Imaging
Imaging applications provide long-range detection for monitoring and navigation.

Description

Imaging applications use the highest pulse power. They use pulse durations to get
reliable long-range detection. The trade-off is a reduction in the ping rate, partially due
to the long range, and partially to maintain power consumption within reasonable limits.

We recommend a maximum vessel speed of five knots for imaging applications.

Details
Sonar Application Names: Imaging

Imaging Enhanced
Range: 0.2 m to 150 m
Angular Resolution: 1.6° x 30°
Pulse Type: Continuous Wave and Linear FM (Chirp)
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Advanced menu
The Advanced menu is intended for experienced users or for testing purposes and is not
required for normal operation of the Flexview. This menu requires a software license
key, and will not appear if you do not have one.

How to open

To open this menu, click the menu title.
Description
• Power User Settings

Click to open the Power User Settings
dialog box. The Power User Settings dialog
box allows you to configure advanced
controls. You can also override the beamlist
or processing type during playback. The
Ping Rate, Update Rate, and Mode ID are
displayed for your information.

• Program Head

Click to open the Program Head dialog box. You can perform advanced tasks in the
Program Head dialog box, such as configuring production settings, making head
corrections, or changing transmit pulse definitions. This dialog box is only available
when the Sonar Head is connected and paused.

• Raw Data Frequency Spectrum

Click to open the Raw Data Spectrum window. The Raw Data Spectrum window
allows you to find and observe any noise in the data.

• Enable Network Sniffer

Click to open the Network Sniffer window. The Network Sniffer window allows you to
monitor network traffic in real-time. When this feature is enabled, the menu option
will change to Disable Network Sniffer.

Note

To use this feature, you must run the Flexview software as an administrator
(right-click on the icon and select Run as administrator).

Topics
Power User Settings dialog box, page 137

Program Head dialog box - Production Config page, page 139

Program Head dialog box - Head Corrections page, page 141

Program Head dialog box - TX Pulse page, page 143

Raw Data Spectrum window, page 144
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Power User Settings XML file, page 145

Power User Settings dialog box
The Power User Settings dialog box allows you to configure advanced controls. You can
also override the beamlist or processing type during playback. The Ping Rate, Update
Rate, and Mode ID are displayed for your information.

How to open

This dialog box is opened from the Advanced menu.
Description

Use the Advanced Controls to configure special
processes used during beamforming. Use the
Playback Controls to override the fields of
recorded “.mmb” data during playback. You can
also view detailed system information for the
current sonar application.

Details

Advanced Controls

• RX Amplitude and Phase Correction

This feature allows you to make sure the
RX Amplitude and Phase Correction has
been successfully written to the Sonar
Head during production configuration.
Unchecking this box will not apply the
correction stored in the Sonar Head to
the raw data before beamforming.

• Azimuth Processing

This feature allows you to make sure
the raw data is received properly and to
make sure there are no faulty elements
in the transducer. Unchecking this box
will display the range-compressed raw
data in the sonar view with a range vs.
element number instead of a range vs.
beam angle. The beamforming processing (either the time-domain beamformer
or the FFT beamformer) will not be applied.
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• Range Processing

This feature, when used together with Azimuth Processing, allows you to see
the unprocessed raw data received directly from the transducer. If the transmit
pulse is an LFM pulse, unchecking this box will not apply range compression to
the raw data before the beamforming processing.

• Sidelobe Reduction

This function improves overall image quality by reducing the sidelobes of
strong targets. Sidelobe reduction is especially useful at short ranges when
targets are very close.

Note

If automatic sidelobe reduction is enabled in the Display menu, the slider will be
greyed out and you can view the automatically-calculated sidelobe reduction
ratio. If automatic sidelobe reduction is disabled in the Display menu, you can
drag the slider to the right to manually increase sidelobe reduction. On the
highest settings you may notice a black line appearing around the same range
of the bright target.

Playback Controls

Note

You can also edit the Playback Controls settings in the “PowerUsersInfo.xml” file.

• Override Beamlist

This feature allows you to replace the beamlist of a recorded “.mmb” file with a
new beamlist XML file. The recorded raw data will be beamformed based on
the new beamlist. Checking the Override Beamlist box will enable the Beamlist
File field. You can type in the beamlist file’s address or click the folder icon
to browse for it.

• Override Processing Type

Leave this setting as No to use the original processing type for beamforming in
post processing.

System Information

• Ping Rate

The ping rate is determined either by the current sonar application, or calculated
based on the network link speed.

• Update Rate

The update rate is the number of times the sonar view is updated per second.
The displayed ping rate may be different from the update rate because the
system might be impacted by other processes.
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• Mode ID

All sonar applications have their own unique mode number. The mode number
displayed here corresponds to a PRI Sequence ID found in the Flexview
software database.

Related topics
Power User Settings XML file, page 145

Program Head dialog box - Production Config page
You can perform advanced tasks in the Program Head dialog box, such as configuring
production settings, making head corrections, or changing transmit pulse definitions.

How to open

This dialog box is opened from the Advanced menu.

Note

This dialog box is only available when the Sonar Head is connected and paused. To
pause the Sonar Head, click Setup→Connect, then open the Menu Widget in the top-right
corner of the sonar view. Click Pause.

Select the Production Config tab.
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Description

Use the Production Config page to view or change advanced Sonar Head parameters,
such as the Serial Number or MAC Address. This page is primarily intended for use by
production test engineers.

Flexview Reference Manual



922-20207001/1.3 141

Details

Head

The Head table shows you the serial number and IP Address of the Sonar Head.

Configuration file

Click the folder icon to browse for the latest configuration file on your local drive.
Click the Load from file button to populate the Production Configuration fields
with values from your configuration file.

To save the current parameters, locate the field at the bottom of the dialog box
and choose a filename or browse to replace an existing file. Click the Save to file
button beside this field.

Production Configuration

This table lists all the advanced parameters and their values for the Sonar Head.

Write Config

Click this button to re-program the Sonar Head with the parameters displayed
in the Production Configuration table.

Read Config

Click this button to populate the Production Configuration fields with the current
parameter values (values are read from the Sonar Head).

Program Head dialog box - Head Corrections page
You can perform advanced tasks in the Program Head dialog box, such as configuring
production settings, making head corrections, or changing transmit pulse definitions.

How to open

This dialog box is opened from the Advanced menu.

Note

This dialog box is only available when the Sonar Head is connected and paused. To
pause the Sonar Head, click Setup→Connect, then open the Menu Widget in the top-right
corner of the sonar view. Click Pause.

Select the Head Corrections tab.
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Description

Use the Head Corrections page to write Phase/Amplitude Corrections or Range Reference
Coefficients to the Sonar Head. This page is primarily intended for use by production
test engineers.

Details

Head

The Head table shows you the serial number and IP Address of the Sonar Head.

Configuration type

Select the type of configuration you wish to apply.

Configuration file

Click the folder icon to browse for the latest configuration file on your local drive.

Click the Write button to apply the configuration parameters in your file to the
Sonar Head. Click the Read button to save the current Sonar Head configuration to
your configuration file.
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Program Head dialog box - TX Pulse page
You can perform advanced tasks in the Program Head dialog box, such as configuring
production settings, making head corrections, or changing transmit pulse definitions.

How to open

This dialog box is opened from the Advanced menu.

Note

This dialog box is only available when the Sonar Head is connected and paused. To
pause the Sonar Head, click Setup→Connect, then open the Menu Widget in the top-right
corner of the sonar view. Click Pause.

Select the TX Pulse tab.

Description

Use the TX Pulse page to apply a new TX pulse definition to the Sonar Head if a new
TX pulse is designed for the Flexview software database.

Details

Configuration file

Click the folder icon to browse for the latest configuration file on your local drive.

Click the Write button to apply the configuration parameters in your file to the
Sonar Head. Select the box if you wish to load the transmit pulse definitions when
connecting to the Sonar Head.
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Raw Data Spectrum window
The Raw Data Spectrum window allows you to find and observe any noise in the data.

How to open

This window is opened from the Advanced menu.

Description

This window displays the normalized, real-time raw data spectrum. The baseband
sampling frequency range of the received signal is shown on the x-axis, and the
normalized spectrum amplitude is shown on the y-axis (in dB). You can also view the
carrier frequency of the raw data, the normalized transmitted signal frequency spectrum,
and the maximum signal strength averaged across the elements.
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Power User Settings XML file
The Power User Settings XML file allows you to change advanced Flexview software
parameters by editing the file with any text editor.

How to open

Note

Close the Flexview software before editing the Power User Settings XML file.

Download and install a free XML file editor, such as Notepad++. Navigate to
C:\KML\Flexview_V0131\bin\SettingsFlexView. Open the “PowerUsersInfo.xml”
file with your XML file editor.

Description

You need a software license key to apply the values in the “PowerUsersInfo.xml” XML
file to the Flexview software. If you do not have a software license, then the default
values will be used. The new values will be applied after restarting a licensed copy of
the Flexview software.
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Details

<PlaybackOverrideBeamlists>

This feature allows you to replace the beamlist of a recorded “.mmb” file with a
new beamlist XML file. The recorded raw data will be beamformed based on the
new beamlist. Enter a value of “Yes” or “No” in the XML tag.

<OverrideBeamlistFile>

Enter the beamlist file’s address into the XML tag.

<ProcessingTypeOverride>

Enter a value of “Yes” or “No” in the XML tag. Leave this setting as No to use the
original processing type for beamforming in post processing.

Note

The other parameters in the Power User Settings XML file are for profiling applications
only and are not supported by the Flexview.

Related topics
Power User Settings dialog box, page 137
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Help menu
The Help menu allows you to view hardware and software information in the About
Flexview dialog box. You can also open the Flexview Reference Manual from this menu.

How to open

To open this menu, click the menu title.
Description

About dialog box

The About dialog box identifies the current software version.
The version described in this publication is 1.3.1.

User Manual

Click User Manual to open the Flexview Reference Manual in PDF format. This manual
is only applicable to the software version you are using. If you are using an older version
of software, it will not be the latest version.

Tip

You can download the latest software from http://www.km.kongsberg.com/mesotechsoft-
ware, and the latest manuals from http://www.km.kongsberg.com/mesotechdocumenta-
tion.
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Tool bar description
The tool bar provides buttons for functions, filters, and sonar view overlays.

The tool bar provides access to useful functions, such as the ability to take a screenshot
or change your TVG settings. In addition, several measuring tools are available.
A Arrow

Click to use the default arrow cursor. With the default cursor you can select and
manipulate objects on the screen.

B Wiper

Removes items from the sonar view. When selected, click on each overlay you
wish to delete.

C Zoom windows

You can open up to four true zoom windows when running a Sonar Head.
D Tape Measure

Measures distances on the sonar view. Also allows you to place a measurement
overlay on the sonar view.

E Protractor

You can use the protractor to measure the angle between two lines, then place the
resulting overlay in the sonar view.

F String Measure

You can use the string measure tool to define an area. The size and perimeter of the
area will be calculated for you.

G Text Label

The text label tool allows you to place comments on the screen.
H Reference Cursor 1

I Reference Cursor 2

You can place one or two reference cursors as overlays on the sonar view. When
you place two cursors, an additional overlay will appear with information about the
cursors.
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J Image Quality Analysis System

The Image Quality Analysis System (IQAS) analyzes the image quality of a point
target, or can be used to measure a known point target against a specification.

K Y1

Horizontal line overlay that can be used to mark the depth of the natural seabed (for
use when excavating).

L Y2

Horizontal line overlay that can be used to mark the depth of a trenching target (for
use when excavating).

M Show Full Screen

Click Full Screen to make the sonar view full screen. Press the Esc key to exit
full-screen mode.

N Save image with overlays

Click this button to save sonar view images, including any overlays you’ve placed
in the sonar views.

O Save image without overlays

Click this button to save sonar view images, excluding any overlays you’ve placed
in the sonar views.

P TVG Setup dialog box

TVG (Time Variable Gain) compensates for the loss of acoustic energy due to
geometric spread and absorption.

Q Average Filter

Clicking the “A” button will enable the Average Filter. This filter reduces noise.
Slow-moving features persist on-screen.

R Background Removal

Clicking the “B” button will enable the Background Removal filter. This filter
removes stationary parts of the background to enhance moving objects (such as
fish, for example).

S Edge Enhancement

Clicking the “E” button will enable Edge Enhancement. This filter enhances the
edge of moving features.

T No Filter

Disables any filters. The sonar view will display an unfiltered sonar image.

Topics
Arrow, page 150

Wiper, page 150
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Zoom windows, page 150

Tape Measure, page 151

Protractor, page 152

String Measure, page 152

Text Label, page 152

Reference cursors, page 153

Image Quality Analysis System, page 153

Save image with or without overlays, page 154

TVG Setup dialog box, page 155

Filters, page 158

Arrow
Click to use the default arrow cursor. With the default cursor you can select and
manipulate objects on the screen.

If you are currently using one of the tools, such as the Tape Measure for example,
clicking the Arrow button will cancel the current tool.

To move overlays around in the sonar view, click the Arrow button, then click and
hold the left mouse button on an overlay. Drag it to where you want it then release
the mouse button.

Wiper
Removes items from the sonar view. When selected, click on each overlay you wish
to delete.

If your sonar view becomes too cluttered with overlays, you may wish to remove
some of them.

Click theWiper button, then left-click on any overlay that has been placed in the sonar
view (such as a Reference Cursor, for example) to remove it. Note that you cannot
undo this action.

Zoom windows
You can open up to four true zoom windows when running a Sonar Head.

To open a zoom window, click the Zoom windows button in the tool bar, then
click a target of interest in the sonar view.

The zoom area (A) in the sonar view is a fixed size and cannot be adjusted. However,
you can move the zoom area to another location with the cursor. The images in the true
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zoom windows (B) are acquired separately using high-resolution sampling parameters
and adequate transmit pulses.

If you record sonar data while the zoom windows are open, the zoom window data will
also be recorded for replay. During playback, the zoom windows will open automatically.

Tip

Reference cursors can be used with a Zoom window. To make fine adjustments to the
cursor position, drop a reference cursor into a Zoom window.

Tape Measure
Measures distances on the sonar view. Also allows you to place a measurement overlay
on the sonar view.

To measure the distance between two targets, click the Tape Measure button.
Click and hold the left mouse button on your first target, then drag the mouse to
your second target. The length and bearing between the targets is displayed dynamically.
The measurement line will not remain on the display when you release the mouse button.

To place a persistent measurement overlay, click and hold the right mouse button on your
first target, then drag the mouse to your second target and release the mouse button.
Click the left mouse button to place the overlay.

Tip

Once the measurement overlay is placed, you can use the default arrow cursor to drag
the length and bearing label to a position on the screen where it is more legible.
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Related topics
Measuring distances, page 57

Protractor
You can use the protractor to measure the angle between two lines, then place the
resulting overlay in the sonar view.

The protractor tool measures the angle between a baseline and a second line that
intersects the baseline.

In the sonar view, click the point where you want to start the baseline. Click the point
where you want to end the baseline. Lock one end of the second line to the baseline.
Choose where you want the second line to end.

Related topics
Measuring angles, page 58

String Measure
Defines and measures perimeters and areas. Allows you to place an area overlay on
the sonar view.

To define an area, click the String Measure button. Click anywhere in the sonar
view to start a point. Move to the second point, then click again. Click as many
times as necessary to create the required area. Double-click on the last point to finish.
The area will automatically be closed, and a rectangular label will appear providing
information about the area and perimeter. Move the label to a position on the screen
where it is most legible, then click the left mouse button to place it.

Tip

You can place multiple areas on the display. The areas will remain on the display until
you delete them individually with the Wiper function.

Related topics
Defining an area, page 58

Text Label
The text label tool allows you to place comments on the screen.

Click the Text Label button. In the sonar view, click the area of interest that
you want to label. Click and hold the left mouse button on the label overlay
and drag it to a place on the screen where the text is legible. Double-click on the label
overlay to open an Edit Text Box dialog box.
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Tip

If the text you entered does not fit within the text label overlay, you can resize the label by
clicking on the label border, then dragging it to create a larger label.

Related topics
Placing text labels, page 59

Reference cursors
You can place one or two reference cursors as overlays on the sonar view. When you
place two cursors, an additional overlay will appear with information about the cursors.

To mark a point of interest, you can place a cross-hair type marker on
the sonar view. Click one of the Reference Cursor buttons. Choose where
you want to place the cursor, then click the left mouse button to place it. The range
and bearing of the cursor’s position — relative to the Sonar Head — is shown in the
bottom-left corner of the view.

When you place both cursor 1 and cursor 2 on the sonar display, the cursor range and
bearing — relative to the Sonar Head— will be displayed. “Delta” shows the range and
bearing from cursor 1 to cursor 2.

Related topics
Placing reference cursors, page 60

Image Quality Analysis System
The Image Quality Analysis System (IQAS) analyzes the image quality of a point target,
or can be used to measure a known point target against a specification.

IQAS measures a known point target against a specification, such as resolution,
Peak Side Lobe Ratio (PSLR), or Integrated Side Lobe Ratio (ISLR).

To enable IQAS, click the IQAS button on the tool bar.

Two IQAS dialog boxes will open. One dialog box shows the range (in metres), and the
other shows the azimuth angle (in degrees).

Move the IQAS cursor to a target of interest in the sonar view, then click the left mouse
button to place the cursor.
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The following information will be displayed in the two IQAS dialog boxes.

Resolution, Impulse Response Width (IRW)
The IRW is measured 3 dB down from the top of the Main Lobe of the impulse response.
In the range dialog box, the IRW is displayed in pixels and metres. In the azimuth angle
dialog box, the IRW is displayed in pixels and degrees.

Peak Side Lobe Ratio (PSLR)
The PSLR is the Peak Side Lobe level in the Near Region relative to the level of the
Main Lobe. The unit of measurement is dB.

Integrated Side Lobe Ratio (ISLR)
The ISLR is the ratio of the energy in the Near Region to the energy within the Main
Lobe Region. The unit of measurement is dB.

Save image with or without overlays
With one click, you can capture an image of the sonar view — either with overlays or
without overlays.Click this button to save sonar view images, including any overlays
you’ve placed in the sonar views.
Click the Save image with overlay button to save the sonar view image,
including any overlays (such as the Tape Measure or Text Labels for
example) you’ve placed in the sonar view. If you want to save the sonar view without
overlays, click the Save image without overlay button instead.
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Your images will be saved under the folder “C:\KML\Flexview_V0131\Images” by
default. You can change this save location through the Preferences dialog box.

A text file with information on the image capture sonar settings will also be created.

Tip

Open the Preferences dialog box to change the default save location, choose your own
filename, and add overlay text.

TVG Setup dialog box
When an acoustic pulse is sent through the water, it will gradually lose its energy. The
greater the distance between the transducer and the target(s), the greater the loss of
energy. TVG (Time Variable Gain) compensates for the loss of acoustic energy due to
geometric spread and absorption.

How to open

Note

Each sonar application has its own TVG profile. Before changing the TVG settings, start
the sonar (click Setup→Connect), then select the sonar application you want to configure
from the Sonar applications list. The TVG profiles will not be saved when closing the
software — default values will apply when starting up the Flexview software.

Click the TVG button. This button is located on the tool bar.
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Description

When an acoustic pulse is sent through the water, it will gradually lose its energy.
The greater the distance between the transducer and the target(s), the greater the loss
of energy.
• Geometric spread

Once transmitted, the acoustic energy will spread out to form a circular beam. The
width of this beam increases with the physical distance to the target(s).

• Absorption loss

Depending on the salinity and temperature, the water will absorb some of the energy
from the acoustic transmission. The absorption loss increases as the physical distance
to the target(s) increases.

Both the geometric spread and the absorption will also have an effect on the returned echo
signal. That is why we normally refer to these factors as the two-way transmission loss.

The TVG (Time Variable Gain) compensation is designed to counteract the natural
phenomena of geometric spread and absorption loss. In the Flexview system, the TVG
compensation is made using digital signal processing software. By means of algorithms,
the time variable gain compensation converts the echo presentation as a function of
range. This makes the targets with the same strength appear with the same intensity
independent of their physical distance from the transducer.

Details

The TVG compensation is expressed as a logarithmic curve. You can choose from
a selection of curves. Each curve has a different slope creating a different gain
compensation. Four adjustable factors are used to set the gain curve.

A Factor

Represents spreading loss.

B Factor

Represents one-way absorption loss.

C Factor

Represents a base or starting gain level.

L Factor

Limits the maximum gain to reasonable levels.

To the left of the TVG curve display is a slider with a range from -30 to 130. This
represents the system gain. Moving this slider down until the line intersects the green
TVG curve will cause a Range-Gain pair of values to be displayed in the “Range-Gain”
box. Adjust this slider to determine the gain at a particular range.

If you have a software license for advanced features, then an additional pane and slider
bar will become available. When the Sonar Head is running, a graphic representation
of the receive signal will appear at the bottom of the dialog box so that you can ensure
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that the signal is not being clipped. A slider is provided so that you can exclude the low
end percent of the gain.

Related topics
Adjusting the TVG (Time Variable Gain) setting, page 36

Functions and dialog boxes



158 922-20207001/1.3

Filters
You can apply an averaging, background removal, or an edge enhancement filter to
the sonar view.

Note

You can adjust the strength of these filters in the Display Widget.

Average Filter

Clicking the “A” button will enable the Average Filter. This filter reduces noise.
Slow-moving features persist on-screen.

This filter averages the image from ping to ping so that slow-moving features will
persist, while reducing noise in the image. The Average Filter is especially useful when
the image is constructed from multiple pings.

Background Removal

Clicking the “B” button will enable the Background Removal filter. This filter removes
stationary parts of the background to enhance moving objects (such as fish, for example).

Edge Enhancement

Clicking the “E” button will enable Edge Enhancement. This filter enhances the edge
of moving features.

This filter provides some persistence for the image. Edge Enhancement is especially
useful when you wish to view a school of fish clearly, for example.

No Filter

Disables any filters. The sonar view will display an unfiltered sonar image.

No filtering is preferable if instantaneous readings are required, since this shortens the
delay between updating the changes in sonar data, and the corresponding displayed
information.

Related topics
Applying filters, page 36
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Technical specifications

Topics
Introduction to technical specifications, page 160

Interface specifications, page 161

Performance specifications, page 164

Mechanical specifications, page 166

Power requirements, page 167

Environmental requirements, page 167

Minimum computer requirements, page 168
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Introduction to technical specifications
These technical specifications summarize the main functional and operational
characteristics of the Flexview Multibeam sonar. They also provide information related
to power requirements, physical properties and environmental conditions.

Note

At Kongsberg Mesotech, we are continuously working to improve the quality and
performance of our products. The technical specifications may be changed without
prior notice.
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Interface specifications
The Flexview system will interface with peripheral systems and sensors using standard
and/or proprietary datagram formats.

Supported datagram formats for GPS (position) information

The Flexview system supports the following datagram formats for position information:
• NMEA GGA

The NMEA GGA datagram transfers time-, position- and fix-related data from a
global positioning system (GPS).

• NMEA GLL

The NMEA GLL datagram transfers the latitude and longitude of vessel position, the
time of the position fix and the current status from a global positioning system (GPS).

• GGK

This third party datagram format contains the vessel’s current position with the
assigned coordinated universal time (UTC) of position, as well as a selection of
position quality factors.

Supported datagram formats for speed information

The Flexview system supports the following datagram format for speed information:
• NMEA VTG

The NMEAVTG datagram contains the actual course and speed relative to the ground.

Supported datagram formats for heading information

The Flexview system supports the following datagram formats for vessel heading and/or
gyro information:
• NMEA HDG

The NMEA HDG datagram provides heading from a magnetic sensor. If this reading
is corrected for deviation, it produces the magnetic heading. If it is offset by variation,
it provides the true heading.

• NMEA HDM

The NMEA HDM datagram provides vessel heading in degrees magnetic. The
datagram is no longer recommended for use in new designs. It is often replaced
by the NMEA HDG telegram.

• NMEA HDT

The NMEA HDT datagram provides the true vessel heading. The information is
normally provided by a course gyro.
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• EM Attitude 3000

The Kongsberg EM Attitude 3000 is a proprietary datagram format created by
Kongsberg Mesotech for use with digital motion sensors. It holds roll, pitch, heave
and heading information. The datagram contains a 10-byte message.

• Octans STD1

This is a third-party proprietary datagram format for heading, speed, and motion. It
was created by iXSea (http://www.ixblue.com) for use with their Octans gyrocompass.

Supported datagram formats for motion information

The Flexview system supports the following datagram formats from a motion sensor:
• Teledyne TSS1

Teledyne TSS1 is a proprietary datagram format for heave, roll and pitch
compensation. When you select this protocol, the number of sensor variables is fixed,
and there is no token associated with it.

• EM Attitude 3000

The Kongsberg EM Attitude 3000 is a proprietary datagram format created by
Kongsberg Mesotech for use with digital motion sensors. It holds roll, pitch, heave
and heading information. The datagram contains a 10-byte message.

• Octans STD1

This is a third-party proprietary datagram format for heading, speed, and motion. It
was created by iXSea (http://www.ixblue.com) for use with their Octans gyrocompass.

Supported datagram formats for sound speed sensors

The Flexview supports the following datagram format from a sound speed sensor.
• Valeport

This is a third-party proprietary datagram format created by Valeport Ltd. for use
with their sound velocity sensors. The file format is ASCII. There are three formats:
standard format (millimetres per second), alternative format #2 (metres per second
with two decimal places), and alternative format #3 (metres per second with three
decimal places). For more information, see http://www.valeport.co.uk.

Supported datagram formats for depth information

The Flexview system supports the following datagram formats for depth output:
• NMEA DBT

The NMEA DBT datagram provides the current depth under the transducer. In new
designs, this datagram format is frequently used to replace the DBK and DBS formats.

• NMEA DPT

The NMEA DPT datagram provides the water depth relative to the transducer, and
the offset of the measuring transducer.
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Processed data formats

The following processed data output formats are available.
• .mmb

This is raw element data, not beamformed, in a 16-bit fixed-point complex format.
This format allows great flexibility in how the data is processed and allows you to do
your own beamforming or profile-point extraction. The data body size is determined
by the number of elements and the number of samples.

• .imb

This format consists of beamformed data. Data body size is determined by the number
of beams and samples. Different modes may form a different number of beams.
Therefore, data body size may change depending upon the mode.

Synchronization
• PRI Sync

PRI Sync (set with Trigger Mode on the Sonar Setup page of the System Configuration
dialog box) provides ping synchronization with another Sonar Head or other acoustic
source that supports synchronization (for example, EK60, Sidescan, DVL, etc.). PRI
Sync is a level-sensitive method of synchronization. When the sync is held high, the
sonar will not transmit. The PRI Sync INPUT must be held low for 25μs in order to
trigger the Sonar Head. The Sonar Head will transmit a 100μs sync OUTPUT pulse
when configured asMaster on the Sonar Setup page. The sync OUTPUT is generated
each time the Sonar Head transmits.

• Host Time Sync Mode

Host mode synchronizes the Sonar Head time with the computer time. This mode
is critical for Bathymetry applications. Host mode only works if the computer is
connected to an accurate time source, such as a GPS or network time server. When
connecting to the Sonar Head, it takes two minutes to synchronize the time to within
five milliseconds.

• Computer Time Sync

If ZDA is configured, the Flexview software will use the time in the ZDA message
to synchronize the computer clock automatically in the background. However, you
may need to run the Flexview software as an administrator (right-click on the icon
and select Run as administrator) or Windows may not allow the software to change
the system clock. Computer time sync can be useful when data is being logged on
more than one computer and synchronized timing is required. This method is not
recommended for Bathymetry applications as it is not accurate enough.

Note

Computer time sync requires both GGA and ZDA input.
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Performance specifications
These performance specifications summarize the main functional and operational
characteristics of the Flexview system.
• Range:

– 500 kHz: 0.2 m to >150 m
– 700 kHz - 1400 kHz: 0.2 m to 70 m

• Coverage: 140°
• Range resolution: 1 cm
• Frequency: Dependent on transducer
• Pulse types: CW, CHIRP
• Modes: Dependent on transducer
• Communication: Ethernet
• Data Rates: 10/100 Mbps

Synchronization
• PRI Synchronization (master / slave operation):

– Sync Input: 0 to 5 VDC, hold-off when high
– Sync Output: 0 to 5VDC active low pulse 100μs

Imaging mode — 500 kHz
• Horizontal Field of View: 140°
• Vertical Beamwidth: 30°
• Angular Resolution: 1°
• Update rate: up to 40 Hz

eIQ mode — 500 kHz
• Horizontal Field of View: 140°
• Vertical Beamwidth: 30°
• Angular Resolution: 0.95°
• Update rate: up to 10 Hz

Imaging mode — 700 kHz
• Horizontal Field of View: 140°
• Vertical Beamwidth: 30°
• Angular Resolution: 1.0°
• Update rate: up to 40 Hz
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Imaging mode — 950 kHz
• Horizontal Field of View: 140°
• Vertical Beamwidth: 27°
• Angular Resolution: 0.8°
• Update rate: up to 40 Hz

Imaging mode — 1200 kHz
• Horizontal Field of View: 75°
• Vertical Beamwidth: 21°
• Angular Resolution: 0.65°
• Update rate: up to 40 Hz

Imaging mode — 1400 kHz
• Horizontal Field of View: 45°
• Vertical Beamwidth: 18°
• Angular Resolution: 0.55°
• Update rate: up to 40 Hz

VDSL

Firmware version: 1.5

Part number: 320-27701000-0150 (Rx controller)

Important

Although VDSL sonar heads are pre-programmed at the factory with the correct
firmware, you may need to upgrade your firmware if you do not have the latest version
for your VDSL Sonar Head. For the best performance, firmware version 1.5 (or later) is
required for applications using a long cable and VDSL telemetry. Note that you only need
to upgrade the Sonar Head receive firmware file (.RXF) and the Sonar Head software file
(.ASW). You do not need to upgrade the Sonar Head transmit firmware file (.TXF).

You can download these files from our website.

• https://www.km.kongsberg.com/mesotechsoftware
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Mechanical specifications
These mechanical specifications summarize the physical properties of the Flexview
system.

Sonar Processor
The Sonar Processor uses a high-quality commercial-off-the-shelf laptop computer
workstation. The weight and dimensions of the model may vary. Contact your
Kongsberg Mesotech representative for information about the current model that is
delivered with your Flexview system.

500 kHz Sonar Head
• Depth rating: 300 m
• Dimensions

– Diameter: 169 mm (6.65”)
– Height: 86 mm (3.40”)
– Depth: 240 mm (9.45”)

• Weight: 3.85 kg (air), 1.38 kg (water)
• Materials: Hard Anodized Aluminium, Stainless Steel 316, Elastomeric Polyurethane
• Connector type: SubConn®

• Connector model: 8 pin

700-1400 kHz Sonar Head
• Depth rating: 300 m
• Dimensions

– Diameter: 169 mm (6.65”)
– Height: 86 mm (3.40”)
– Depth: 249 mm (9.82”)

• Weight: 3.75 kg (air), 1.38 kg (water)
• Materials: Hard Anodized Aluminium, Stainless Steel 316, Elastomeric Polyurethane
• Connector type: SubConn®

• Connector model: 8 pin

VDSL
Cable requirements: One twisted pair (100-ohm impedance)
Note

VDSL will work over two wires. Actual data rate will vary with the cable quality.
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• 3 m (10 foot) cable: Up to 100 Mbps
• 152 m (500 foot) cable: Up to 100 Mbps
• 1000 m (3300 foot) cable: 27 Mbps (measured on Belkin 1353A)

Power requirements
These power characteristics summarize the supply power requirements for the Flexview
system.

Sonar Processor
• Power adapter input voltage: 120/240 VAC
• Laptop input voltage: 19.5 VDC @ 180W (max)

Sonar Head
• Input voltage: 12 to 36 VDC
• Input power: 22W (avg.), peak power < 60W, mode dependant
• Maximum cable loop resistance for Sonar Head power:

– 0.1 Ω @ 12VDC
– 2 Ω @ 24VDC
– 6 Ω @ 36VDC

Note

These values were measured at +23°C.

Environmental requirements
These specifications summarize the temperature requirements and other environmental
standards for the Flexview system.

Sonar Processor

The Sonar Processor uses a high-quality commercial-off-the-shelf laptop computer
workstation. This computer is intended to be installed inside in an area suitable for
extended human habitation. Contact your Kongsberg Mesotech representative for
information about the current model that is delivered with your Flexview system.

Sonar Head

Operating temperature: -2° to + 38 °C

Technical specifications
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Storage temperature: -40 to +55 °C
The stated operation temperature range is for the Sonar Head in water. The Sonar Head
can be powered on and started at temperatures between -20° to +45° C. There is a built-in
temperature monitor that will display a software warning message and automatically
power down the Sonar Head before it overheats.
Caution

The Sonar Head must not be exposed to direct sunlight for prolonged periods of time.
Prolonged exposure to ultra-violet rays and excessive heat may damage the surface of
the polyurethane transducer face. Store the Sonar Head in a cool, dry location away
from ozone sources (such as electric motors or welders).

Minimum computer requirements
Although a computer can be ordered from Kongsberg Mesotech as a part of the Flexview
system delivery, it is also possible to purchase one locally.
If you purchase a computer locally, make sure that the chosen model meets the functional
and technical requirements.
It is important that the chosen computer model is relatively new with sufficient processing
power, a high performance graphics adapter, and a high speed Ethernet adapter.
We recommend a computer with a CPU that has a PassMark Software benchmark score
of 14,000 or more (passmark.com).
PassMark Software is a Windows computer performance benchmarking utility.
Computers with a CPU score of 14,000 or higher have been tested with the Flexview.
Lower-scoring computers may not perform well, resulting in a slow GUI response,
slower ping rates, or dropped pings.
When running two Flexview Sonars, an average CPU Mark of 30,000 is recommended.
The computer must be able to facilitate the various interface requirements made by the
Flexview system, and you may need to add extra Ethernet and/or serial adapters.
Note

The computer design and construction must allow for maritime use. Easy access to
connectors, parts and cables must be provided. Make sure that the installation method
allows for the physical vibration, movements and forces normally experienced on a
vessel.

The minimum technical requirements are:
• Microprocessor: 2.80 GHz, Intel quad core i7
• Memory: minimum 8 GB
• Hard disk: minimum 500 GB

Flexview Reference Manual
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• Graphics card RAM: 256 MB
• Network interface: 100/1000 Mbps
• Serial adapters: One or more serial line interfaces are required. The number of serial

lines depends on your interface requirements.
• Operating system: The Flexview software has been designed for the Microsoft® 64-bit

Windows 10 operating system. Windows 7 is supported for imaging applications
only. Profiling applications will not work properly in Windows 7. Operating systems
older than Windows 7 are not supported.

Technical specifications
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